[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: My Debian Woody installation won't boot

On Fri, Aug 23, 2002 at 11:22:49PM +0100, Dave Turner wrote:
> 1)
> At 20:11 -0700 2002/08/21, Chris Tillman wrote:
> > > FYI. It took three attempts to get Alt-F2 to work, press too early
> >> and the install screen goes red and the keyboard locks up!
> >
> >That's interesting. How exactly did you get it to do that?
> >Do you hold the Alt (Option) key and then press F2?
> I do hold the Alt (Option) key and then press F2 - say 0.25 to 0.5 
> seconds later.
> The red install screen and the locked keyboard are the result of 
> pressing Alt-F2 whilst the console stuff is streaming by (with the 
> penguin gazing down). If I wait until the 1st install screen - 
> "Choose Language" comes up then it works OK.

Oh, that makes sense then. The init hasn't started yet, so the 
consoles haven't been established. God knows what program trapped
your keystroke.

It was a nice exercise in communication breakdown...

> 2) /etc/yaboot.conf : no such file or directory
> /etc has 25 files in it and 3 of them are .conf namely:-
> ld.so.conf
> modules.conf
> nsswitch.conf
> 3) typing "nano-tiny /mnt/yaboot.conf"
> opens up yaboot.conf in the nano-tiny editor.
> It looks like this:-
> boot=/dev/hda2       (my 800K bootstrap partition)
> device = hd:
> partition=12            (the Linux partition)
> root=/dev/hda12
> timeout=30
> install=/usr/lib/yaboot/yaboot
> magicboot=/usr/lib/yaboot/ofboot
> image=/vmlinux
> 	label=Linux
> 	read-only
> I had a look at /usr/lib/yabooy/yaboot.
> It looks like this:-
> lrwxrwxrwx  1  root     root   22 May 16 14:32 /usr/lib/yaboot -> 
> /target/usr/lib/yaboot
> ofboot is not present, so whatever magicboot is, it is certainly wasting 
> its'
> time.

It will come into play later, after you get your installation booted.

> /target/usr/lib is not there either.
> 4) >what's your /etc/yaboot.conf look like?
> now that I know how to find it I can tell you that it is not there!

I meant /target/etc/yaboot.conf.
> > >If it's not, that is totally strange. Maybe you can get more information
> > >by running mkofboot manually:
> > >
> > >cp /target/etc/yaboot.conf /etc/yaboot.conf
> > >mkofboot -v
> and would you believe that /target/etc/yaboot.conf is not there?
> And that mkofboot refuses to run until I have mounted the root and 
> /usr filesystems on /target and /target/usr.
> I copied /mnt/yaboot.config into the /etc directory but it did not help.
> I have done a bit of reading on "mount" and none of it was friendly or 
> easy...
> I tried various permutations of mount / /target
> mount -t hfs /dev/hda2/ /target
> but all of my attempts were rejected.
> So. How do I mount my root and /usr filesystems on /target and 
> /target/usr so I can run mkofboot in verbose mode to get more info on 
> what is going on?

OK. /target is where your root partition should be mounted. This will 
be done for you by the installer, if you go through those steps when
you start up.

Configure keyboard
activate swap
mount root partition
mount usr partition
configure network
-- at this point it will recognize that you already have a base
  installation and will move you to Make System Bootable from Hard disk.

Go ahead and try the make System Bootable command, that should insure
that /target/etc/yaboot.conf will be created. Then you can switch to
console 2 and try the cp and mkofboot -v to see what messages it might

> At this point I had brainwave and tried
> mount /dev/hda12 /mnt
> which let me look at the actual Linux partition to see what is there. 
> All sorts of things!
> The files pointed to by install= and magicboot= in yaboot.config are 
> present.

Congratulations, you're learning how flexible and powerful linux is.

> If install= and magicboot= aretrying to point to filees on the hda12 
> Linux partition then I think that the link between hda2 and hda12 is 
> broken.
> If they are expecting to find them on hda2 then should I copy the 
> files from hda12 and into hda2?

No, definitely don't copy anything to hda2. You just mounted it once
to take a look under the hood and make sure something's there. The
bootstrap partition belongs to mkofboot and ybin; they have to perform
magic in order for it to work.

ybin/mkofboot depend on your yaboot.conf to tell them how to operate;
and the yaboot.conf you typed above looks right.

To learn more about them, once you get into the real system, you 
can man ybin, man yaboot, and man yaboot.conf. You can also check
out the HOWTO at penguinppc.org which is linked to from the 
install manual.

>From what you have written, everything looks like it should for you 
to be able to boot. In fact, running mkofboot probably won't show 
anything odd, but it's just a last attempt to figure out what might
be going on.

After you run mkofboot, and if it says everything's OK, it should

*------v--------- Installing Debian GNU/Linux 3.0 --------v------*
|      <http://www.debian.org/releases/stable/installmanual>     |
|        debian-imac: <http://debian-imac.sourceforge.net>       |
|            Chris Tillman        tillman@voicetrak.com          |
|                  To Have, Give All to All (ACIM)               |

Reply to: