[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: My Debian Woody installation won't boot

At 20:11 -0700 2002/08/21, Chris Tillman wrote:
 > FYI. It took three attempts to get Alt-F2 to work, press too early
 and the install screen goes red and the keyboard locks up!

That's interesting. How exactly did you get it to do that?
Do you hold the Alt (Option) key and then press F2?

I do hold the Alt (Option) key and then press F2 - say 0.25 to 0.5 seconds later. The red install screen and the locked keyboard are the result of pressing Alt-F2 whilst the console stuff is streaming by (with the penguin gazing down). If I wait until the 1st install screen - "Choose Language" comes up then it works OK.

2) /etc/yaboot.conf : no such file or directory

/etc has 25 files in it and 3 of them are .conf namely:-

3) typing "nano-tiny /mnt/yaboot.conf"
opens up yaboot.conf in the nano-tiny editor.
It looks like this:-

boot=/dev/hda2       (my 800K bootstrap partition)
device = hd:
partition=12            (the Linux partition)

I had a look at /usr/lib/yabooy/yaboot.
It looks like this:-
lrwxrwxrwx 1 root root 22 May 16 14:32 /usr/lib/yaboot -> /target/usr/lib/yaboot

ofboot is not present, so whatever magicboot is, it is certainly wasting its'

/target/usr/lib is not there either.

4) >what's your /etc/yaboot.conf look like?
now that I know how to find it I can tell you that it is not there!

 >If it's not, that is totally strange. Maybe you can get more information
 >by running mkofboot manually:
 >cp /target/etc/yaboot.conf /etc/yaboot.conf
 >mkofboot -v

and would you believe that /target/etc/yaboot.conf is not there?

And that mkofboot refuses to run until I have mounted the root and /usr filesystems on /target and /target/usr.

I copied /mnt/yaboot.config into the /etc directory but it did not help.

I have done a bit of reading on "mount" and none of it was friendly or easy...

I tried various permutations of mount / /target
mount -t hfs /dev/hda2/ /target

but all of my attempts were rejected.
So. How do I mount my root and /usr filesystems on /target and /target/usr so I can run mkofboot in verbose mode to get more info on what is going on?

At this point I had brainwave and tried
mount /dev/hda12 /mnt
which let me look at the actual Linux partition to see what is there. All sorts of things!
The files pointed to by install= and magicboot= in yaboot.config are present.

If install= and magicboot= aretrying to point to filees on the hda12 Linux partition then I think that the link between hda2 and hda12 is broken. If they are expecting to find them on hda2 then should I copy the files from hda12 and into hda2?

DT -- on Friday evening - keeps me out of the pub I suppose.

Reply to: