[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: My Debian Woody installation won't boot

This will be done for you by the installer, if you go through those steps when
you start up.

Configure keyboard
activate swap
mount root partition
mount usr partition
configure network
-- at this point it will recognize that you already have a base
  installation and will move you to Make System Bootable from Hard disk.

Go ahead and try the make System Bootable command, that should insure
that /target/etc/yaboot.conf will be created. Then you can switch to
console 2 and try the cp and mkofboot -v to see what messages it might

the results of typing "mkoofboot -v" are:-
mkofboot: Creating HFS filesystem on /dev/hda2
mkofboot: Installing first stage bootstrap /usr/lib/yaboot/ofboot onto /dev/hda2
mkofboot: Installing primary bootstrap /usr/lib/yaboot onto /dev/hda2
mkofboot: Installing /etc/yaboot.conf onto /dev/hda2
mkofboot: setting attributes on ofboot
mkofboot: setting attributes on yaboot.conf
mkofboot: Blessing /dev/hda2 with Holy Penguin Pee
mkofboot: updating OpenFirmware boot-device variable in nvram
mkofboot: Installation complete

The files on /dev/hda2 are the same six as before, this time with the date stamp of Aug 24 19:45, so we know they are new.

The newly created yaboot.conf file is exactly the same as before.

I allowed the system to reboot and got the usual blank screen.
And as usual I had to use the Mac OS CD to get the system up and running.

I have the feeling that Debian is doing its' best to get itself up and running but OpenFirmware won't let it.

I never even knew Open Firmware existed before I started considering Open Source software.
I have found two peculiarities about my system.
1) the "dir" command won't work in my Open Firmware
2) the "\" key won't work in my Open Firmware
(it is more precise to say it is "unavailable" - I tried many keys and combinations to find out where it might be hidden)

Apple TN2001 gives an example of :-
0 > dir hd:\

And I can't even type it in!
dir on it's own throws an error.
dir hd: throws the same error.

My Apple iMacOpen Firmware is 3.0.f2 built on 04/23/99 at 14:31:03

Any ideas on the best thing to do now?

DT - half irritated and half refusing to be beaten!

Reply to: