[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: PM 7500 won't install s/w

on 14/02/2002 04:49, Michael Schmitz at
schmitz@opal.biophys.uni-duesseldorf.de wrote:

>> i have an HFS hard drive that i've downloaded stuff from the FTP mirror, and
>> i've mirrored it on the drive. now, i can mount it, and i can cd thru the
>> directories, but when i do dselect, it can't find the s/w, and i get errors.
> Don't do that, then. The errors you get are from files named confusingly
> similar to the actual packages, in subdirectories named .resource and
> .finderinfo (IOW, HFS metadata crap). Since dpkg descends into every
> directory looking for these files (using a 'find' subprocess) you'd have
> to hack dkpg to omit directories named .resource or .finderinfo.
> When I tried that a couple of years ago I gave up due to generic
> dpkg build problems. Should not be too difficult with recent dpkg
> actually.

ok, thanx. um, how would u hack dpkg? it's my 4th day on debian. i'm used to
resedit tho, so i have an idea of what that hack implies.

also i'm having problems getting pppoe to work. and i haven't a clue which
file to edit. i've tried just about everything. mind u, i've managed to
install several things by using dpkg, mounting the HFS partition manually,
then going down to that sub-dir, and installing from there. which is
arduous, to say the least. it' more dselect that i'm having a problem with,
since i haven't able to get the pppoe to work (as above; i'm using the
stable version in the binary section) and the problem of dselect not seeing
the HFS partition (prolly for the reasons u mention above).

> Obvious workaround: copy the packages to a sane filesystem before use.
> ISO9660 qualifies, BTW.

no CD burner.

> Other workaround: figure out the proper HFS mount option to omit the
> metadata if that's possible.

that, or rebuild the kernel - as suggested to me on the IRC channel
(#debian, on irc.debian.org).

thanx again

> Michael

Reply to: