[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: pbg4 modem wakup

Am 29.12.2001 10:07 Uhr schrieb "Michel Lanners" unter <mlan@cpu.lu>:

> On  28 Dec, this message from P Prince echoed through cyberspace:
>>> I have read in the archives, that the modem of the pbg4 (titanium 1st
>>> generation) needs some time to wake up. So I know, that some programs can
>>> not detect the modem imediateley. But I am completely unable to wakeup my
>>> modem and I did not find any messages of somebody who sucessfully used his
>>> modem. I tried the following things:
> [snip]
>> Also, check your kernel configuration.  The 1st run TiG4 does have a hardware
>> modem.  Perhaps Mac serial support is required?  I don't think setserial is
>> needed, but if it is, it certainly doesn't take standard x86 values.  My
>> modem
>> is on IRQ 53.
> Yes, the modem needs time after the serial port has been opened, since
> the modem is powered off as long as nobody has /dev/ttyS0 open. But
> definitely, starting minicom on /dev/ttyS0 and just waiting for some
> time (a few secs) should be OK; after that, the modem should respond to
> the usual at commands (try atiX, where X=0...9).
but my modem does not respond to any commands. Is there some way I could
debug this? Should I see some kernel messages in the logs? I waited for at
least 30s. I even tried in single user mode to be sure that no other process
blocks the modem. I also unloaded all irda stuff (by the way this works, so
macserial should be ok in principal).

> First thing, check your kernel logs. Here is what my first-gen PBG4
> reports:
> macserial: i2c-modem detected, id: 1
> PowerMac Z8530 serial driver version 2.0
> tty00 at 0xc9902020 (irq = 22) is a Z8530 ESCC (internal modem)
> tty01 at 0xc9909000 (irq = 23) is a Z8530 ESCC (IrDA)
mine reports the same whenever i load macserial.o

I do really not know whats wrong, because it seems to work for others using
the same setup. My kernel is 2.4.17-ben0 rsynced on 12/28/2001 (image
downloaded from debian.jones.dk)

I would like to have some hints on how to debug the problem further or on a
bullet-proof way of waking up the modem.

> You definitely should get the same IRQ values; but IO port may be
> different depending on hardwre config and kernel version.
> If you don't get the above, make sure macserial is loaded (and don't
> compie standard serial into your kernel), and try again.
> Michel
> -------------------------------------------------------------------------
> Michel Lanners                 |  " Read Philosophy.  Study Art.
> 23, Rue Paul Henkes            |    Ask Questions.  Make Mistakes.
> L-1710 Luxembourg              |
> email   mlan@cpu.lu            |
> http://www.cpu.lu/~mlan        |                     Learn Always. "

Reply to: