[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Booting into Linux on OldWorld Mac

On Thu, Dec 13, 2001 at 10:44:07AM -0500, Michael Dartt wrote:
> The saga continues....
> Machine: Performa 6400/180, Open Firmware version 2.0
> I've got the Debian base distribution installed.  After getting my hands on 
> Boot Variables, reading all the docs I could find, coming up with variations on 
> what the docs said (since the values given didn't work), and trying about 20 
> different combinations, I've managed to get to an Open Firmware prompt!  
> Here's the wall I'm running into: OF keeps telling me "CLAIM failed" when I try 
> entering "BOOT".  "Linux" gets "linux, unknown word".  Right before the prompt, 
> the OF screen says: 
> boot ata/ATA-Disk@0:5/boot/vmlinux-2.2.19-pmac root=/dev/hda5 
> can't OPEN
> The string after "boot" is what I have in the "boot-file" field of Boot 
> Variables.  My boot-device is "ata/ATA-Disk@0:0".  /target/etc/quik.conf 
> says "image=/boot/vmlinux-2.2.19-pmac" and "root=/dev/hda5".  (hda4 is swap; 
> the first three partitions are the Apple partition map and the ATA drivers.)
> I've tried a variety of variations on the boot-file entry: deleting the "root" 
> statement, changing the boot-command from "boot" to "Linux", and 
> adding "/target" to the beginning of the paths.  I've been doing it 
> incrementally, only changing one thing at a time.
> Sorry for being so windy, but it's been two weeks and I'm so close!  :)  Does 
> anyone have any ideas?

Not sure if I have any other ideas, but I can tell which stuff you're
trying won't work.

The boot command must start with boot. OpenFirmware doesn't understand
Linux. In the docs, when I mention trying to type Linux, it's at the
boot: prompt, which is what quik will give you if you ever get it
booted from OF.

/target also oesn't belong anywhere in this equation, that's only
valid in the installer environment.

boot-file and boot-device, in your case, should be

setenv boot-device ata/ATA-Disk@0:5
setenv boot-file /boot/vmlinux-2.2.19-pmac root=/dev/hda5

If you just type boot in OF, then it adds on boot-device and boot-file
and tries to boot that combination. That's what is failing for you. 

What worked for me was typing in different possibilities directly into
OF until I found the one that booted quik. Then after figuring out
which one works, set the boot-device and boot-file accordingly.

Also, try to do it in two stages. OpenFirmware really doesn't care
about boot-file, it just passes it on to quik. So, if you can get a
quik prompt using just boot-device, then you can experiment at that
point with boot-file.

Here are some boot commands I'd try typing in directly:

0 > boot ata/ATA-Disk@0:5
0 > boot ata/ATA-Disk@0:0

If those don't work, type devalias to get a list of device
aliases. Pick some of those and substitute it for the ata/ATA-Disk@0
part above. (Always add a : and partition number). Try them leaving
off the @0 part too. If none of these work, try 

0 > dev / ls

That will show you an entire tree of devices on your system, you put
together an entire path from the indented pieces. Add :0 or :5 onto
some of the paths you figure out.

If you get quik booting, then first try 

boot: Linux

at the boot prompt. If that doesn't work, (it should) then try
entering the path to the kernel, for example the boot-file you have

If none of those work, you're probably stuck with BootX. See
instructions on that, at least for booting the installer, in this list
the last few days.

*------v--------- Installing Debian GNU/Linux 3.0 --------v------*
|      <http://www.debian.org/releases/woody/installmanual>      |
|   debian-imac (potato): <http://debian-imac.sourceforge.net>   |
|            Chris Tillman        tillman@azstarnet.com          |
|                   May the Source be with you                   |

Reply to: