[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Yet another question on yaboot/ybin


>What version of yaboot are you using? Something better than 1.2.1 I
>would think would have a better chance.

Oops, sorry about omitting important details... I was using yaboot 1.3.5 
(from debian package of course!)

>You might try leaving out the comma if there's no partition
>number. I'm sure its needed if you put in the partition number, but I
>seem to remember in my experiments that it wasn't if you are not
>entering a partition number. Or OTOH cd:1,/vmlinux might be even

I haven't tried leaving out the comma yet - I will try it tonight. I did try 
cd:1,/vmlinux but it didn't work. (Can't find the Elf image or something like 

>One idea is to try to put yaboot on the cd also, I think by default it
>looks on the same drive from which it was booted. Which might allow
>you to just type /vmlinux.

>Another idea is to put a yaboot.conf with an image label on the CD
>too, then you'll be able to type the label. Theoretically.

I tried out both methods and haven't succeeded. It seems that OF cannot find 
yaboot image on the CD.

Perhaps I should rephrase my question to get closer to the solution;

1) Which partition type (for CD) is OF capable of reading? Pure ISO9660? 
ISO9660+hfs hybrid? What about Rock-Ridge extensions?

2) Which partition type is yaboot capable of reading (among the above types)?


Joongul Lee 

Reply to: