[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Endless Problems with XF86Config, what am I doing wrong?

on 11/12/01 9:31 AM using moldy cheese mikeyukish@psu.edu engraved this

> At 03:15 PM 11/12/01 +0100, Michel Dänzer wrote:
>> Mike Yukish wrote:
>>> I tried BootX with "no video driver" forced, and then (from the
>>> LinuxPPC FAQomatic) tried the kernel arguments:
>>> video=controlfb:vmode:13,cmode:16  3
>> It's been a long time since I last used BootX, but these two settings
>> sound contradictory. Try not forcing "no video driver".
> Oops, I meant to say "I first tried checking 'no video driver', then I
> tried not checking 'no video driver' and passing kernel arguments." Neither
> case worked.
> ***********************************
> Mike Yukish
> Head, Manufacturing Product & Process Design Department
> Applied Research Lab/Penn State University
> may106@psu.edu
> (814) 863-7143
> --
> To UNSUBSCRIBE, email to debian-powerpc-request@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

mike, i run a 8500/150 which is similar to your 7600, and this is how i got
X to run on my machine...

check 'no video driver' set machine  in Mac OS to 832x624 or 1024x768
at thousands of colors... (no kernel command line options...) then boot into
linux and go to XF86Config '/usr/X11R6/lib/X11' and go to the section
labeled 'screen' and make sure for 'modes' it says "default" (with the
double quotes) and for defaultcolordepth make sure it says 16 and then in
the subsection for displaymake sure there is an entry for depth of 16...

this is my section 'screen':

Section "Screen"
    Driver      "FBDev"
    Device      "Linux Frame Buffer Device"
    Monitor     "Generic Monitor"
    DefaultColorDepth   16

    SubSection "Display"
        depth       16
        modes       "default"


and it works fine... the only caveat i have is when in X and the screen
blanks out it will crash the X server and will go back to a text console...
to aleviate this put the following into /etc/X11/xdm/Xsetup :

xset s noblank

and also into your xsession file...

this should get you running... as i ran into all the problems you have had
(only difference is i got them 2 weeks ago ;')


Reply to: