[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: installation success using 3.0.16 on iBook Dual USB / HOWTO

On Sun, Nov 11, 2001 at 05:12:56PM -0900, Ethan Benson wrote:
> On Sun, Nov 11, 2001 at 09:37:26AM -0700, Tom Rini wrote:
> > 
> > So what happens exactly?  Can you reproduce this on something and decode
> > the oops?  Looking in 2.4.15-pre2 I don't see the mac partition table
> > stuffs not doing something the msdos ones do..
> enter the `w' command to commit a new partition table
> mac-fdisk writes out the new one, synced the disk
> mac-fdisk calls the reread ioctl
> kernel panics (sometimes)

Hmm.  I wonder if there's something wierd (and out of Linux's) hands
going on.  I remember trying to track this down when I worked for
LinuxPPC, Inc.  Things go horribly wrong if the disk is still mounted.
But that's not the case here.

> one other note that just occured to me, i could only reproduce the
> problem on that G4 *once* and that one time was when i obliterated the
> crufty partition table containing all the macos crap, all subsequent
> partition tables were free of any driver cruft, only pure linux
> partitions and an Apple_Bootstrap.  when setting it up i intentionally
> tried writing a few new tables just to see, could never reproduce it
> again. 

Perhaps OF 'opens' up something on the driver partitions and it's never
closed.  I'm not totally sure myself, but I'm sort-of sure it's not a
Linux bug.  It's always possible, but it'd be a mighty strange race to
be in both 2.2 and 2.4...

Tom Rini (TR1265)

Reply to: