[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Installation Success on PowerPC SMP G4 w/ ADC monitor - but whence GLX?

Hello, fellow PowerPC linux users. :)

After many years away, I decided to return to the PowerPC linux scene,
since my macintosh is rediculously faster than my PC and I end up
spending most of my time there so I can run apt.

So, here's my story.

My machine is a dual 500MhZ G4 with 256M of RAM and an ATI Rage 128 card
connected to Apple's most recent 17 inch CRT via the Apple Digital

I burned a Potato ISO (R2.2r3) a while back, and booted up off of it.
Initially, the machine would boot from the cd (by holding down 'c' at
boot) but would quickly go to a black screen.  I discovered that by
entering Open Firmware and typing

    boot cd:\\yaboot

I was able to get to a boot prompt, at which I ran

    install video=ofonly

From there, the install process proceeded smoothly. I created an Apple_Bootstrap partition of the appropriate size and name, went through the various installation screens, and rebooted.

The first reboot didn't work, but booting once from the CD (with root=/dev/hda13) and running mkofboot && ybin got me to the point where the OF graphical boot menu showed me tux sitting comfortably next to the appropriate partition. The installer *really* ought to do that for you, and it would be nice to see the warning about needing an 800k boot partition of the right type before being dropped to pdisk; I'm glad I read the online instructions first, because just the installer screens would have baffled me.

Upgrading to sid was seamless except for the fact that python-gtk is broken right now, which is really annoying :).

After monkeying with it for a bit, I eventually figured out that video=ofonly was not the only way to get video to work. Adding append="video=aty128fb:vmode:20:cmode:14" to yaboot.conf also made my system bootable, and I was eventually able to discover why:

It seems that the ADC connector is *VERY* picky about what refresh rates/pixel clocks/etc it will accept. Plugging in a VGA monitor to the VGA port on my Rage128 showed that it would boot and display graphics just fine; I am aware that the 'vmode' option is deprecated, but I was unable to get a value inside my monitor's highly picky refresh range using the new-style syntax for modes. I have got fbset information for 2 modes on this monitor now; 1024x768@99 and 1280x1024@75. I still haven't gotten X to come up in 1024x768 yet. If anyone is interested, I will post my XF86Config-4 and fb.modes files.

I installed the 2.4.12-powerpc-smp kernel image package, and that appeared to work with my SMP. However, the r128 module for DRI doesn't come with that kernel, so I built my own (with r128 and DRI both compiled in, not as modules), from linus's 2.4.14 tree.

Although I get the output I expect from the diagnostic tool:

    glyph@zelda:~% glxinfo | grep direct
    direct rendering: Yes

running glxgears will hang my X server until it is killed -- except for the hardware cursor, which appears to keep displaying just fine. Apparently there are no ill effects to doing this (I've been running for 24 hours since the last time I tried it) but it does not display the friendly MesaGL demo that I have come to know and love.

I also tried rsyncing to benh's tree, but that didn't build and I didn't have time to troubleshoot it yet.

Does anyone else have experience getting GLX up and running on this setup?

Thanks in advance.

Reply to: