[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: nano: On Oldworld PowerPC, nano freezes machine when help is being displayed

> > you get a panic message, and what did it say?). Further, it would help
> > tremendously if you could pinpoint the exact ioctl or other syscall
> > causing the hang using strace. If there's no panic my best guess is you
> > cause a deadlock by one particular ioctl or a particular sequence of
> > ioctls. (That would be stuff for linuxppc-dev, then.)
> Well I've attached a couple of straces. For the one from 1.0.5, I typed in
> 'added info' to the doc (you can see the keystrokes in the strace) then used
> Ctrl-O to try to save the file. The "File name to write" dialog comes up,
> then it crashes after pressing Return. The strace file didn't get written to very
> much after "File name to write".

And that's why it's missing the interesting bits (it seems to stop with
the read(0 expecting your input). If you type anything but return does it

> Then I tried 1.0.6, it does crash also. For that strace, I opened a new
> file, typed a single X, then Ctrl-O. After it appeared to freeze, I verified
> that I was still able to ping the computer from another, so I tried several
> keystrokes such as Ctrl-C, Ctrl-Q, Ctrl-S, Ctrl-K. But the strace didn't
> record much after the X, and after I rebooted it looked like fsck had joined
> it with a dpkg release file piece.

That should never happen -

> I also tried logging in thru ftp from the other computer as I was completing
> commands. I was able to fetch the trace file at each step until hitting the
> Return key, then the ftp command hung also (remote server has closed
> connection).

Better not dump the log to a file at all, serial might do better (I've
never tried to pipe some output through ssh but even that might work

> (I'm going to have to trash this system and start over when this is done...
> which is not really a big deal.)

I'll try to reproduce this with my Lombard (which is newworld so it might
not show up). What ncurses version did it start happening with,
approximately (or around what date; I guess I can try to dig through the
buildd logs for clues then)? And what processor/video hw/disk does the
oldworld box have?


Reply to: