[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Unable to boot Potato from Pismo HD


Subject says it all.

Hardware: Powerbook G3 (Pismo) 400/320

Software: Official Debian Potato CDs / MacOS X

Have partitioned HD as per instructions:

800 KB Apple_Bootstrap partition at hda2

320 MB Linux swap partition on hda

2.0 GB LInux partition on hda

(also have an Apple partition map at hda1, a MacOS X partition and Apple Disk Driver partitions)

When booting from the Potato CD, everything works fine right through the set-up, including the "make Debian bootable from HD" step. I assume therefore, that the necessary boot files are getting written to the bootstrap partition but I have no idea how to check this. Anyway...

Upon reboot I can only get OS X from the HDD. Have tried to boot using yaboot via open firmware. No dice. I don't know the exact syntax for booting via open firmware. Have tried:

boot (x):(y),yaboot

where (x) and (y) are taken from:


I always get one of two types of error. Either "cannot open partition" or "invalid command"

Well, I'm a novice. Only thing I can think to try is an install of MacOS 9 so that I can run the BootX control panel/extension? Don't want to install MacOS 9 if I can possibly avoid it though.

Anybody got any advice?

Thanks in advance,


Reply to: