[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]



I finally had the time to give a good look at this pre-built kernel-image (I know, took me long enough :-), and got it working, but with a couple of problems along the way.

Hardware: Motorola StarMax 3000/160 (pmac 4400 clone, 160 MHz 603e), built-in Mach64 VT 1MB, PCI MacPicasso 540 (Cirrus Logic GD5480 chipset, 4 MB).

   * Using BootX, it always boots with the console on the Mach64,
     unless I check the "No video driver" box.  (Didn't have a VGA
     monitor to see what was wrong until this morning, the MacPicasso
     has that funny Apple monitor port.)  This behavior is different
     from 2.2.19, but I'm not sure whether it should be considered a
   * When I check "No video driver", most of it is fine, but there are
     color blocks with little circles in them between "VFS: diskquotas
     version..." and "Console: switching to colour frame buffer...",
     which look like what I used to get with CONFIG_VGA_CONSOLE=y, as
     this kernel has.  But this is merely a cosmetic problem AFAICT.
   * The machine hangs when trying to set the clock.  I notice there
     are two rtc.o modules, in drivers/char and drivers/macintosh.
      Could the kernel be trying to load the wrong one?  Worked around
     this by setting HWCLOCKACCESS=no in /etc/default/rcS, but then I
     have to rdate...
   * The machine hangs while "Starting printer spooler:".  Could it be
     trying to insmod parport.o?  Worked around by purging lprng.

So now I'm up and running with 2.4.8, but the 3nd and 4th problems above should probably be worked on.

Oh- and the openafs module builds and works! Would anyone like me to upload it?


-Adam P.

GPG fingerprint: D54D 1AEE B11C CE9B A02B  C5DD 526F 01E8 564E E4B6

Welcome to the best software in the world today cafe! <http://lyre.mit.edu/%7Epowell/The_Best_Stuff_In_The_World_Today_Cafe.ogg>

Reply to: