[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Woody Boot Floppies Report



On Sat, Jun 16, 2001 at 09:06:42AM -0400, Russell Hires wrote:
> Okay,
> 
> No success just yet. I was able to boot using the kernel and booted into
> the ramdisk (named root.bin), but the kernel panicked. (I'm a holdout
> for BootX, BTW. I still like it, and I'm still dual booting, as I share
> my computer with the computer illiterate :-) The error message is:
> Exception PC C00D7980 Signal 4. So, I rebooted using the same kernel,
> and every thing was peachy.

what machines do you have?  if its a newworld you will get no
support.  use yaboot not BootX.  Any bug report from a NewWorld
hardware user booting with BootX will not be considered.  its caused
by BootX period.  

> The install was going well according to the steps laid out, until I got
> to the install kernel modules part: I got unresolved symbols errors for
> several of the modules (sorry I don't remember which ones, I'll take

we know about these, its not a failure.  every single debian kernel i
have ever seen has had this issue, not just on powerpc either.  i
don't know why...

> better notes next time) and the installer wanted the directory structure
> to be like it expected: powermac/images-1.44/rescue.bin. I had to rename
> the directory holding images-1.44 to powermac from something else...

i don't understand why some people have to do this, i never have.  i
just installed where i had the rescue.bin and such in simmply
/instmnt/install/*  it worked fine.  a week ago i did it with the
files in /instmnt. 

> The next thing was setting up the network. To my surprise, when I chose
> to set things up via DHCP, it worked. Or so I thought...when I try to

your dsl device must have a dhcp daemon running on it, giving out
bogus info...

> connect to the net, I can't, because I have DSL connection that uses
> PPPoE. This is where the base tarball would have helped me out a lot.

i don't know what can be done about that hideous thing known as
pppoe.   but the base tarball is dead and will likely never return.  

> So, I got stopped at the network. I'm going to have to figure out a way

> It seems that the Woody boot floppies are attempting to be boot once, do
> a complete install from there, and keep on truckin' after that; Rather
> than boot once, get some basic stuff working, reboot, get the rest of
> the system going...

no its not, it works exactly as potato did in that respect, the only
difference is the base install uses real .debs rather then a precooked
root filesystem tarball.  the base you get installed from woody's
installer is pretty much the same as the one in potato.  very small
and limited, just enough to boot and get you on your way to using
dselect/tasksel to make things useful.  

the reason we killed the base tarball was because it was a nightmare
to maintain/build and required a rebuild of the boot-floppies just to
update a package in base, debootstrap eliminates all that hassle.

-- 
Ethan Benson
http://www.alaska.net/~erbenson/

Attachment: pgp9iFNNMRom7.pgp
Description: PGP signature


Reply to: