[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: problem booting from sda during installation



On Fri, Oct 06, 2000 at 09:38:43AM -0700, Indraneel Majumdar wrote:
> 
> I thought any space after the first 128MB is left unused. Is this
> incorrect? (previously swap partition _had_ to be less than 128MB to work
> but that I guess was rectified).

yes that is an anchient long gone limitation of 2.0 kernels, 2.2 has
never had this problem.

your swap partition can now be up to 2GB on 32bit platforms and
alot bigger on 64bit platforms

> I did. mac-fdisk is working fine, it was always working fine. I have
> partitions like this now (in a bid to make easy test cycles):
> Apple Partition map
> /   2.1GB
> It still doesn't boot from sda
> 
> I'll explain again: I can stick in the boot floppy and install over NFS.
> Everything is fine. I follow the installation menu and come to where it
> wants to make linux directly bootable from hard disk. That happens (it
> runs quik) and then wants to reboot. It reboots, ejects root floppy, and
> shows gray screen of "?". Here is the quik.conf I can see when I boot
> using floppy and mount the sda at /target:

yes you need to fix OF first, you do this by running 

nvsetenv boot-device <path>

where <path> is the OpenFirmware path to the disk.  the ofpath utility
included with recent ybin distributions has some support for oldworld
macs, i don't think its been tested on an 8550 however.  

> partition=2	## does not work even with partition=1

partition=2 is correct, that is your root partition.  

> root=/dev/sda2
> timeout=100
> image=/vmlinuz
> label=linux
> read-only

this looks ok

> I am able to run quik after booting from floppy with -C option. This is
> the output:
> 
> Second-stage loader is on /dev/sda2
> Config file is on partition 2
> Writing first-stage QUIK boot block to /dev/sda2
> Making /dev/sda2 bootable (map entry 2)
> Writing block table to boot block on /dev/sda2

looks good.

> This is part of the dmesg output:
[snip]
> --------------------
> 
> If this gets solved, we'll put debian on 2 more macs, so I'm really biting
> my nails.
> Thanks,
> Indraneel

i am sure all you need to do is reconfigure OpenFirmware.  this is not
done automatically unfortunatly.  (though now it could on some
machines using ofpath)

-- 
Ethan Benson
http://www.alaska.net/~erbenson/

Attachment: pgpFLMjTrrRst.pgp
Description: PGP signature


Reply to: