[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: problem booting from sda during installation


sorry for this late followup. I was busy with PostgreSQL. but potato is
still not booting on my 8550. Sorry for the long post, please help:

On Tue, 26 Sep 2000, Ethan Benson wrote:

> On Wed, Sep 27, 2000 at 02:23:24AM -0700, Indraneel Majumdar wrote:
> > 
> > I've downloaded potatoPPC 1st CD and have mounted it -o loop on my
> > SuSE/intel box and then exported it via nfs. I made boot and root disks
> > and installed the basic system on our PowerPC Workgroup Server 8550/200
> > with 2GB sda. Partitions look like:
> > Apple Partition map
> > /	1.2GB
> > /var	600MB
> > swap	100MB
> > swap	100MB
> ok, not sure i get why you have 2 swap partitions, is this two disks?
> or are you under the impression that the linux kernel still has a
> limit of 128MB on swap partitions?

I thought any space after the first 128MB is left unused. Is this
incorrect? (previously swap partition _had_ to be less than 128MB to work
but that I guess was rectified).

> > after first reboot it asks for floppy again and doesn't boot from sda.
> > Booting from floppy is fine and I can also chroot to /target and work
> > there (but I can't continue the install). I've also tried to make
> > Apple_Bootstrap partition as hfs using MacOS CD and tried using ybin but
> don't do that, you cannot use the MacOS partitioner to create
> GNU/Linux partitions including the bootstrap partition.  see:
> http://www.alaska.net/~erbenson/doc for help on partitioning with
> mac-fdisk.

I did. mac-fdisk is working fine, it was always working fine. I have
partitions like this now (in a bid to make easy test cycles):
Apple Partition map
/   2.1GB
It still doesn't boot from sda

I'll explain again: I can stick in the boot floppy and install over NFS.
Everything is fine. I follow the installation menu and come to where it
wants to make linux directly bootable from hard disk. That happens (it
runs quik) and then wants to reboot. It reboots, ejects root floppy, and
shows gray screen of "?". Here is the quik.conf I can see when I boot
using floppy and mount the sda at /target:

partition=2	## does not work even with partition=1

I am able to run quik after booting from floppy with -C option. This is
the output:

Second-stage loader is on /dev/sda2
Config file is on partition 2
Writing first-stage QUIK boot block to /dev/sda2
Making /dev/sda2 bootable (map entry 2)
Writing block table to boot block on /dev/sda2

This is part of the dmesg output:

scsi0 : MESH
scsi1 : 53C94
scsi : 2 hosts.
mesh: rejecting message from target 0: 1 1 3
mesh: bs0=2f in msg_out
mesh: rejecting message from target 0: 19
mesh: bs0=2f in msg_out
mesh: rejecting message from target 0: f
  Vendor: SEAGATE   Model: ST32550N          Rev: 3705
  Type:   Direct-Access                      ANSI SCSI revision: 01 CCS
Detected scsi disk sda at scsi0, channel 0, id 0, lun 0
  Vendor: ARCHIVE   Model: Python 02830-XXX  Rev: 576B
  Type:   Sequential-Access                  ANSI SCSI revision: 01
  Vendor: MATSHITA  Model: CD-ROM CR-8008    Rev: 8.0e
  Type:   CD-ROM                             ANSI SCSI revision: 02
Detected scsi CD-ROM sr0 at scsi1, channel 0, id 3, lun 0
scsi : detected 3 SCSI generics 1 SCSI cdrom 1 SCSI disk total.
Uniform CD-ROM driver Revision: 3.11
SCSI device sda: hdwr sector= 512 bytes. Sectors= 4194058 [2047 MB] [2.0
eth0: MACE at 00:05:02:68:d9:09, chip revision 25.64
Partition check:
 sda: sda1 sda2

If this gets solved, we'll put debian on 2 more macs, so I'm really biting
my nails.

> on other thing, you mention this is a 8550?  is this correct? if so

yeah, machine is a 8550/200

> you cannot use ybin/yaboot, as your machine is not a Newworld.  the
> bootloader you want is quik.  also the bootstrap partition is not of
> much use on oldworld macs unless you want to try and mess with
> miboot.  (which i don't want to go into..)
> > I'm obviously getting stuck somewhere. Can someone help? I'm using Mac for
> > the first time and have never worked on MacOS before (so I couldn't follow
> > many of the archive threads). I'm debating whether to use LinuxPPC but
> > debian is such a nice distro (on intel at least) that I don't want to
> > leave it.
> we need some more info, but i think your problem is trying to use
> yaboot on an oldworld, that won't work.  
> -- 
> Ethan Benson
> http://www.alaska.net/~erbenson/

# Indraneel Majumdar                  ¡  E-mail: indraneel@123india.com  #
# Bioinformatics Unit (EMBNET node),  ¡  URL: http://scorpius.iwarp.com  #
# Centre for DNA Fingerprinting and Diagnostics,                         #
# Hyderabad, India - 500076                                              #

Reply to: