[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Mac-On-Linux - elf32_getehdr failed

I've just managed to get Debian installed on a PowerMac 4400/200.
The base install
wasn't too hard, but getting X to work was a bear.

Finally, I've gotten X to work.

Now I'm trying to get Mac-on-Linux (MOL) to work. If you're at
all familiar with MOL, you know it's very Redhat-centric. So
rather than try to work with the RPM, I tried to compile it from
source, but I kept running into a "can't find curses.h" problem.
I also see this problem when trying to run "make menuconfig"
(although this problem may be related to dialog.h instead of
curses.h; the error message is: "dialog.h:29: curses.h: No such
file or directory").

This is really more of a curiosity than a problem at this point,
but does anyone know what's up with the missing "curses.h"? I
found very little on the web about this subject.

So I gave up on trying to compile the source code, and used alien
to install the MOL RPM. Since the 4400 is a 603(e), MOL couldn't
apply run-time patches to the kernel, which forced me to run a
MOL-supplied patch and recompile the kernel. Since I had read
that 2.2.15 had problems (which is what I started with on this
Mac), I downloaded the source for 2.2.16 (I couldn't find 2.2.16
on the Debian site, only older versions and 2.2.17pre6 -- why
isn't 2.2.16 there? aren't the even-numbered versions stable and
the odd ones developmental?) from one of the major sites
(linux.org? linux.com? I don't remember now). I applied the patch
and then compiled the kernel, turning on the MOL component.

After the reboot, everything looks fine, but when I try to run
"startmol" it complains about a ROM image. Doh! I knew that. So I
downloaded the utility to take a snapshot of the Mac ROM, and
moved the image to /usr/lib/mol/rom/rom.nw and pointed my
/etc/molrc to that file. This time, "startmol" does better, but
 Running in PowerPC 750 mode (G3)
 newworld: elf32_getehdr failed
 cleaning up...
 Terminating threads

Is the claim of running in G3 mode significant, since I don't
have a G3 but rather a 4400?

I searched the web for "elf32_getehdr failed" and found very
little; just the printf lines in some code that apparently
generate this error message. Thinking that maybe some package
needed to be installed, I tried to "apt-get install libelf", but
it complained that libelf conflicted with libelfg0, and when I
tried to remove libelfg0, it complained that it was being
depended on by various packages, such as make and dpkg. I wasn't
about to hose dpkg by going any further, so I set things back to
the way they should be and decided to ask this list if anyone had
any ideas.


Kent West

Reply to: