[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: powerbook keymap doesn't work after install

Chris Baker <electro@trylon.1939worldsfair.com> writes:

> Hello all,
> I just went through the potato installer on my powerbook 3400c and it
> went pretty well (including the ethernet--woohoo!).  There was an
> error configuring the keyboard saying it couldn't find the keymap, but
> the keyboard worked fine so I didn't think much about it.  After I
> went through the whole installation and rebooted, everything came up
> fine, and got to the md5 password setup, but the keymap was completely
> screwed up.
> Anyway, the keyboard worked in the installer, so my question is what
> do I have to copy over from the ram disk to make the keyboard work?

O.k. I found the answer to this in the archives (after spending
forever reading about keymaps, loadkeys, etc.), but the responses
seemed to imply that the person must be using some old version of the
boot floppies.  I was using the latest files from ftp.us.debian.org,
which I assumed would be the latest available :-(

The workaround, in case you're keeping score, is to boot back to the
installer, mount your root partition, and delete




Then you can boot back to your new installation, and it'll run
kbdconfig automatically.

Aside from that, everything went smoothly (there were other parts of
the installer that didn't work, but I seemed to be able to ignore them

I really like the new setup, BTW.  And powerpc has come a long way in
past year or so that I've been following it, both in the installer and
the documentation, so I really want to say `good work' to everyone

Thanks again,


Reply to: