[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Feedback (2000-03-16)

Sergio Brandano wrote:
>  Cheers,
>  Sergio
>  (hardware: PowerBook Lombard G3-400)
> 1. Result of booting today's rsync tree:
> Machine check in kernel mode. (regs at cb491bf0)
> Caused by (from srr1): Unknown values in srr1
> NIP: D081332C XER: 20000000 LR: D0813318 REGS: cb491bf0 TRAP: 0200
> MSR: 00001030 [IRDRME]
> TASK = cb490000[211] 'modprobe' mm->pgd cb59f000 Last syscall: 128
> 2. gmix sets Volume (read external speakers) and Speaker
>    (read the PowerBook speakers) the way around. The labeling is
>    misleading, it would be more appropriate to say respectively
>    "External Speakers" and "Internal Speakers".

This is a problem with most sound mixers on the PowerPC, almost all
mixing apps I have tried (aumix, kmix) label External Speakers as Volume
and Internetal Speakers as Speaker. This makes sense (well not really :)
because most PC (and some Macs) have really bad internal sound that is
unlistenable to for long periods of time --- and because most people use
the external speaker jack to connect to their monitors, external
speakers or stereos. But still it is confusing (especially for
Powerbook/iBook/Notebook users) but if you changed it you would probably
have to change every app that goes by this convention. <ikk> 

>    The panel applet for the Volume sets the external speakers,
>    which is not what one wants, at least in this case.

That panel applet should probably be customizable -- I can see on a
Notebook why you would want this.

> 3. GNOME System Information, Detailed Sys info, CPU:
>    - funny symbols appear

I haven't seen this.

>    - the processor is not displayed

Or this.

>    - the temperature is not displayed

I have never seen a program correctly (or at all) display the
temperature on the PowerPC -- I don't know if anyone has created a
program to harness this functionality on the PowerPC.

>    - bogomips: 801.18 (PowerBook Lombard 400Mhz)
>      bogomips from the xterm reports: 526

I haven't seen that bug before. Seems strange to me since doesn't GNOME
get it the same way? At any rate I don't use GNOME currently, so I
wouldn't really know.

> 6. Netscape Communicator/Navigator: great mess, none working.

I've noticed that too. I personally ended up on downloading LinuxPPC
Inc.'s .ppc.rpm and converting it to a .deb using alien. Obviously this
is less then ideal, it's alot of work, you end up with a large
monolithic package (unlike some of the debian packages that break parts
down, such as keeping the java class files in a seprate package).

I should note that that strangely it worked better then installing my
rpm on my previously ydl system -- for some reason, about: protocol and
the license agreement appeared correctly. Then again, maybe because it
was a newer rpm I built it from (although both were Netscape 4.7).

Reply to: