[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: VERY preliminary boot floppies available for testing

On Thu, Mar 02, 2000 at 04:16:49PM -0500, james@netcsi.com wrote:
> Also: I was getting weird 'exec format errors' or some such when
> trying to run executables on the hard drive chrooted.  When I
> tried running them non-chrooted, the kernel tried feeding binaries
> to /bin/sh.  And finally, by dint of waving my hands in front of
> my eyes really fast, blinking, achieving Cathodic Oneness with the
> monitor, etc, I deciphered the messages I was getting from kmod:
> kmod: failed to exec /sbin/modprobe -s -k binfmt-4c46, errno = 8
> kmod: waitpid(11,NULL,0) failed, returning -1.
> ...

Odd.  4c46 is LF; I'm wondering if the binaries are corrupted, or if
the kernel's ELF support went bad.


/--------------------------------\  /--------------------------------\
|       Daniel Jacobowitz        |__|        SCS Class of 2002       |
|   Debian GNU/Linux Developer    __    Carnegie Mellon University   |
|         dan@debian.org         |  |       dmj+@andrew.cmu.edu      |
\--------------------------------/  \--------------------------------/

Reply to: