[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: VERY preliminary boot floppies available for testing

On Thu, Mar 02, 2000 at 01:34:26PM -0500, Daniel Jacobowitz wrote:
> Actually, the kernel and modules are both 2.2.15pre3.  I just kept the
> package version at 2.2.14 for simplicity.

I see.  Well, that explains why insmods weren't getting warnings.
Busybox modprobe doesn't seem to notice or care about the package
version, though.

Also: I was getting weird 'exec format errors' or some such when
trying to run executables on the hard drive chrooted.  When I
tried running them non-chrooted, the kernel tried feeding binaries
to /bin/sh.  And finally, by dint of waving my hands in front of
my eyes really fast, blinking, achieving Cathodic Oneness with the
monitor, etc, I deciphered the messages I was getting from kmod:

kmod: failed to exec /sbin/modprobe -s -k binfmt-4c46, errno = 8
kmod: waitpid(11,NULL,0) failed, returning -1.

Same (exactly) on to infinity, or at least long after I got sick
of looking at it.  From /usr/include/asm/errno.h:

#define ENOEXEC          8      /* Exec format error */

Hm.  Maybe the base system wasn't installed so smoothly after all.

Now *that's* entertainment.

> I'll have a new build in a few days, with luck.

Looking forward.

James Deikun, Techie(tm), CSI Multimedia
The opinions expressed &c.

Reply to: