[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: PBG3 install comments

> At least I've got X running with XF68_FBDev - can't get Xpmac to do
> anything but give me a blue screen or crash, depending on the version
> I try.  When it didn't crash, it gave me the error about missing font
> "fixed", which I saw on the mailing list archive, never resolved that
> I could see.  Might help to mention the dual X server situation
> somewhere in the installation or other docs on debian.org.

I had that problem , and I solved it by making sure that
all the following fonts (which are hardcoded in Xpmac) are installed:
Misc, Speedo, Type1, 75dpi and 100dpi

> OK, my current problems, more annoying than life-threatening:
> 1. depmod -a gives me:
> depmod: *** Unresolved symbols in /lib/modules/2.2.12/scsi/53c7,8xx.o
> depmod: *** Unresolved symbols in /lib/modules/2.2.12/block/nbd.o
> depmod: *** Unresolved symbols in /lib/modules/2.2.12/misc/dmasound.o
> depmod: *** Unresolved symbols in /lib/modules/2.2.12/misc/nbd.o
> I'm guessing this stemmed from my rather naive emulation of the
> installer's behavior.

I had the same problem after a normal, trouble-free install. My
guess is a mismatch between the kernel and the modules. I compiled
my own kernel and those problems went away.

> 3. I get various pcmcia-related error messages on startup, complaining 
> that /lib/modules/2.2.12/pcmcia does not exist.  How can I remedy this?

Are the pcmcia module(s ?) available?

> 4. After prodding apt through the upgrade process, everything is
> working but console-data, which fails to configure and stops kbd from
> functioning. It starts with:
> Setting up console-data (1999.08.29-9) ...
> grep: /proc/hardware: No such file or directory
> substr outside of string at /var/lib/dpkg/info/console-data.config
> line 354, <STDIN> chunk 4.
> Please report this bug: no keymaps described for architecture powerpc/ 
> at /var/lib/dpkg/info/console-data.config line 652, <STDIN> chunk 4.
> I looked through the outstanding bugs filed against console-data and
> didn't see anything related.  I don't understand what's wrong here at
> all.

Look on the mailing list archives, that's a standard problem. I tried
one of the fixes suggested, and it then installed flawlessly.


Reply to: