[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

PBG3 install comments


Just finally got a debian powerpc install working on my PowerBook G3
(WallStreet), elapsed time 9.5 hours.  Hopefully my comments as someone
who has installed Debian before, but only on Intel, will help...

I was installing on an external Fujitsu SCSI MO drive (DynaMO 640SE).

I had a great deal of trouble in the installer.  Any partitions I
created in the installer were completely nonfunctional.  I ended up
using pdisk from Mac OS instead, which worked.

I was able to get the swap partition to mount from dbootstrap after
that, but just couldn't mount root.  It worked eventually when I
discovered that it was trying to create a partition with 512-byte
blocks when the block size of the disk is 2K.  So I had to manually
make the filesystem with -b 2048.

I also tried the Yellow Dog Linux installer in desperation, which
simply wouldn't recognize the MO drive no matter what I did, and was
nowhere near as flexible as the Debian installer about letting you go
back, force things to happen, etc.

Eventually I got to installing the kernel and modules.  The install
page on www.debian.org doesn't link to modules.tgz and mention that it
is needed; might make sense to do that.  The problem at this point was 
that it couldn't mount the loop filesystem of the rescue disk (or any
other disk I tried), no matter what I did.  For example, I manually
extracted loop.o from the modules.tgz file and tried loading that
instead, but it didn't help.

In fact, I still can't do it even when I have the system installed.

pc01:/> sudo mount -o loop -t ext2 resc1440.bin /floppy
mount: wrong fs type, bad option, bad superblock on /dev/loop0,
       or too many mounted file systems

In dmesg, I see:

VFS: Can't find an ext2 filesystem on dev loop(7,0).

The installer produced a similar error message.

I was able to install the base system without the kernel and modules
off an HFS partition on the internal IDE hard drive, and that worked
fine.  I manually extracted the modules, and aside from some
complaints from moddep and about no PCMCIA support, I was able to get
a booting Debian (woohoo!).

Trying to do an apt-get update and upgrade, a few packages installed,
but then apt just refused to do anything, saying it was failing
preinst on an unnamed package and exiting.  It seemed the version of
apt itself was causing some of the problems, so by asking it to
upgrade itself first, things ran a little better.

Next came X, which was fun.  I couldn't find a Debian package for the
X server, not knowing that xserver-fbdev was what I wanted, so I used
alien a lot and converted lots of Xpmac .rpm's to Debian format.  I
never got anywhere with that.  Finally, I found a reference to
XF68_FBDev somewhere, and downloaded a version.  None of the various
automatic X configurators for other PowerPC Linuxen would work because
they relied on files in /etc/sysconfig; I eventually grabbed a
generator (mouseconfig) for /etc/sysconfig/mouse and got Yellow Dog
Linux's Xconfigurator to work well enough to generate me an XF86Config
file.  The only problem after that was that the backspace and delete
key were not working, just requiring uncommenting some lines in
/etc/X11/Xmodmap (it would seem useful to have these changes in the
version in the xbase-clients package?)

At least I've got X running with XF68_FBDev - can't get Xpmac to do
anything but give me a blue screen or crash, depending on the version
I try.  When it didn't crash, it gave me the error about missing font
"fixed", which I saw on the mailing list archive, never resolved that
I could see.  Might help to mention the dual X server situation
somewhere in the installation or other docs on debian.org.

OK, my current problems, more annoying than life-threatening:

1. depmod -a gives me:

depmod: *** Unresolved symbols in /lib/modules/2.2.12/scsi/53c7,8xx.o
depmod: *** Unresolved symbols in /lib/modules/2.2.12/block/nbd.o
depmod: *** Unresolved symbols in /lib/modules/2.2.12/misc/dmasound.o
depmod: *** Unresolved symbols in /lib/modules/2.2.12/misc/nbd.o

I'm guessing this stemmed from my rather naive emulation of the
installer's behavior.

2. This weird behavior (which I don't see anything about in the BTS).
Is it showing up for other people?

pc01:/> zsh
Segmentation fault

Not a nice way for my favorite shell to behave...

3. I get various pcmcia-related error messages on startup, complaining 
that /lib/modules/2.2.12/pcmcia does not exist.  How can I remedy this?

4. After prodding apt through the upgrade process, everything is
working but console-data, which fails to configure and stops kbd from
functioning. It starts with:

Setting up console-data (1999.08.29-9) ...
grep: /proc/hardware: No such file or directory
substr outside of string at /var/lib/dpkg/info/console-data.config
line 354, <STDIN> chunk 4.
Please report this bug: no keymaps described for architecture powerpc/ 
at /var/lib/dpkg/info/console-data.config line 652, <STDIN> chunk 4.

I looked through the outstanding bugs filed against console-data and
didn't see anything related.  I don't understand what's wrong here at

Thanks for any advice people can give, and sorry for any
misinterpretations on my part, I am new at this, and am not such an
experienced Debian user on the Intel side either - luckily I don't have 
to be, because things work so well there.

Nicholas Riley <njriley@uiuc.edu>

Reply to: