[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

slang1 (<< 1.3) weirdness

This is an odd dependency problem I've been seeing lately from slang1:

lynx-ssl depends on slang1 (<< 1.3)
bb depends on slang1 (<< 1.3)
libggi-target-aa depends on slang1 (<< 1.3)
urlview depends on slang1 (<< 1.3)
gimp depends on slang1 (<< 1.3)

dselect reports this as a dependency conflict even though I have
slang1 1.2.2-0.2 installed.  Now, if I'm reading it correctly those
packages are asking for a version of slang1 -less than- 1.3, which is
what I have so where's the problem?

Could it have something to do with the fact that my slang1 has the
slightly odd version 1.2.2-0.2 instead of something like 1.2.2-2?  Is
that extra dot after the dash screwing up the version comparison?

I realize this is an old version of slang1.  I upgraded to 1.3.9 just
now and get the same dependency problem (though I expected it this
time).  Which leads to the next question... how do I resolve this?  Do
gimp, et al really depend on an old version of slang1?

Reply to: