[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: problems compiling kernel, ...

Ethan Benson wrote:
> On 16/11/99 Kevin Puetz wrote:
> >The following are true:
> >I could not build kernels older than 2.2.12 or so with the new 2.95 gcc
> >I read somewhere that this was known to be broken on x86
> >
> >I therefore inferred:
> >This is a general problem with the kernel and/or gcc, including PPC.
> >
> >This was affirmed when the newer kernel source worked fine.
> AFAIK the only thing that really changed regarding compilers in
> 2.2.12 was to add a check in the Makefile for gcc 2.95 and if that is
> what is being used add the compiler flag -fno-strict-aliasing which
> allows the kernel to be compiled.

But -fstrict-aliasing is not activated by -O2 anymore with gcc 2.95.2 (because
it caused a lot of trouble) so it shouldn't make a difference...


People who are wrong the most are wrong the loudest.
Michel Dänzer                             ///           mdaenzer@earthling.net
                                     __  /// 	     AmigaOS/Linux(Debian/PPC)
Student of computer science at the   \\\///   Team *AMIGA*      ICQ #: 5675698
Swiss Federal Institute of Technology \\\/   AUGS member #163      IRC: CoOpER

Reply to: