[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Home built kernel causes minor XF68_FBDev problems.

I've been running the 2.2.12 kernel from
ftp://ftp.linuxppc.org/kernels/vmlinux-2.2.12.gz, for several months,
it has worked great with my debian installation.  Unfortunately, when I
tried to run MOL, I discovered that I didn't have a System.map
cooresponding to that kernel, and I couldn't find one anywhere.  I tried
installing the 2.2.12 kernel-image deb and copying to the MacOS side for
BootX, but it didn't seem to be configured quite right for my machine (I
can't remember exactly what was wrong). As a result, I figure it was
time to build my own kernel.  I've done it before in the MkLinux world,
this is my first attempt in the debian universe.  I installed the
kernel-doc-2.2.12, kernel-package, kernel-patch-2.2.12-powerpc, and
kernel-source-2.2.12, and followed the instructions in
/usr/doc/kernel-package to configure, build, install, and boot the new
kernel.  Everything works great (including MOL), except that with the
2.2.12 kernel I'm was using, X would come up in 1600x1200 resolution
(and I
could switch to other resolutions with ctrl-alt-keypad +/-).  With the
kernel I built, it comes up in ??? resolution, but I can still switch to
other resolutions the same way.  However, I'm curious what I've done
that it doesn't work the same.  I looked at /var/log/xdm.log, and
discovered I'm getting different output depending on which kernel I use.
Here is a diff of the changes (the < file is the original kernel, and
the >
file is the kernel I built):

< (--) FBDev: Removing mode "800x600" from list of valid
< (--) FBDev: Removing mode "1024x768" from list of valid modes.
(--) FBDev: Removing mode "1152x864" from list of valid modes.
< (--)
FBDev: Removing mode "1280x1024" from list of valid modes.
< (--) FBDev:
Frame buffer device: OFfb ATY,XCLAIM
< (--) FBDev: Video memory: 3750K @
< (--) FBDev: MMIO regs: 0K @ (nil)
> (--) FBDev: Frame
buffer device: ATY Mach64
> (--) FBDev: Video memory: 4092K @ 0x81800000
(--) FBDev: MMIO regs: 2K @ 0x817ff800
< (--) FBDev: Hardware
accelerator: None
< (--) FBDev: No driver support for hardware
> (--) FBDev: Hardware accelerator: ATI Mach64GT (3D
> (--) FBDev: Initializing accel code
> (**) FBDev: Pixmap
cache disabled
> (**) FBDev: Font cache disabled
> mach64CreateGC:
unsupported depth: 16. Using cfbCreateGC instead.
mach64CreateGC: unsupported depth: 16. Using cfbCreateGC instead.
mach64CreateGC: unsupported depth: 16. Using cfbCreateGC instead.

There are 25 more lines like the last two.  I'm pretty suspicious of the
differences between the Frame buffer device, Video memory, and MMIO regs

I'm also a little surprised to see "Hardware accelerator: None" when
the original kernel.  Both xdm.log files say: "Using cfb16 driver".

So after this long explaination, can anybody tell me what is going on?
Have I screwed something up in cofiguring my kernel?

	Peter Canning -- remove nospam. from my address to reply

PS: Here's the final section of my XF86Config (in case it is relevant):

Section "Screen"
    Driver      "fbdev"
    Device      "ATY Mach64"
    Monitor     "Apple Vision 850 AV Display"
    DefaultColorDepth	16
    Subsection "Display"
        Depth       8
        Modes       "640x480" "800x600" "1024x768" "1152x864"
        ViewPort    0 0
        Virtual     1280 1024
    Subsection "Display"
        Depth       16
        Modes       "800x600" "1024x768" "1152x864" "1280x1024"
        ViewPort    0 0
        Virtual     1600 1200
    Subsection "Display"
        Depth       32
        Modes       "640x480" "800x600" "1024x768"
        ViewPort    0 0
        Virtual     1024 768

Reply to: