[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Failed base upgrade to bash 2.02

On Sat, 17 Apr 1999, Konstantinos Margaritis wrote:

> On Sat, 17 Apr 1999, Hartmut Koptein wrote:
> >> When I upgraded all of my base packages, bash broke.  libc6 went from
> >> 2.1->2.1.1 and the current bash binary is dependent on 2.1.  It segfaulted
> >> with the new library when attempting to run the bash.prerm script.
> >> Extracting the new bash binary allowed me to complete the exercise.
> >> 
> >> Seems like bash 2.01 should have depended specifically on libc6 2.1.
> >
> >Feanor: could you look on this and compile a new bash package?
> but... Matt's talking about bash 2.01. The one I uploaded is 2.02. I never even dealt
> with 2.01. and checking my system, bash 2.02 depends on libc6 (>= 2.1).
> Still, I am checking bash now for any trouble in the scripts.

I probably mistated the problem.  I was concerned that in upgrading from
bash 2.01 (from the base2_2.tgz tarball I used to populate my system) that
there is a dependency problem.  You may not see it on 2.02.

In my case, apt updated libc6 2.1 to libc 2.1.1...then it tried to update
bash 2.01 -> 2.02. When it executes bash.prerm using the old version of
bash (linked against libc6 2.1), it segfaults.  I just am concerned that
future versions of bash will be broken in a similar fashion.

Matt Porter
This is Linux Country. On a quiet night, you can hear Windows reboot.

Reply to: