[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

More experiences

This message is to let others with PowerPC's know about my efforts at getting
the Debian base-powerpc.tar.gz loaded and running on my PMAC 7500/200.

I started by taking a bare partition created under LinuxPPC and untarring the
tarball. I next used Quik from LinuxPPC on the MacOS side to make the
partition bootable. I put version 2.1.125 of the LinuxPPC that I compiled on
my machine on this parition.

I copied my existing fstab from LinuxPPC and changed it to only include the
new partition as /. I also copied over my network configuration information
and other goodies that help get me on the internet. I then used the Boot
Variables program on the MacOS side to boot onto the new partition.

This worked 8^O. I was now running Debian based Linux. One problem! No
development tools.

To fix this problem I built the following packages under LinuxPPC as
statically linked programs:

pmacs-utils (clock, nvsetenv, ...)

I installed them on the Debian parition by changing the prefix variable when
performing the install. BTW, I set the prefix with configure to /usr for all
except the pmac-utils which was set to /.

This too worked. I rebooted back into Debian linux. I re-built the most of the
programs under Debian Linux using glibc-2.0.96.

I had some problems with "features.h" and "libio.h". The definition of
_IO_fpos64_t seems to be missing (or not properly included). I will try to
solve this problem over the next couple of nights.

Also, I build egcs with Ada. The Ada compiler portion has some problems that
might need a cross-compiler initially. I will probably look into this over the

Just thought I would share this experience...

Andrew Reynolds

More than just email--Get your FREE Netscape WebMail account today at http://home.netscape.com/netcenter/mail

Reply to: