[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Status of Debian on the PowerMacs?



Dan Jacobowitz <drow@false.org> writes:

> The easiest way will be if he has a free partition.  Untar the base
> tarball which is probably lying in incoming somewhere onto that
> partition, set it as root (Use nvsetenv boot-file 'whereverkernelis
> root=/dev/sdxx').  Then mount the partition with the .debs, or fetch
> them by hand - is ftp in the tarball?  Should be fairly clean.  Kinda.

I tried this and *almost* got it to work.  I took the drive that had
RedHat and I killed its swap partition (about 127MB).  I untarred the
base-powerpc.tar.gz to that partition and played with the boot junk
until I finally got it so that it would boot the Debian partition.

(It took me quite a while to realize that you didn't have to re-run
quik after modifying /etc/quik.conf, and that if you did, you usually
left the system unbootable.  This meant rebooting to MacOS and
re-running quik to fix it.)

Anyway, it gets to the VFS mount stage, output stops, the drive grinds
for a little while, a couple of "route forgot to specify netmask"
messages pop up, and then it hangs.  Though it works fine with the
RedHat partition.

I was wondering if the Debian stuff might be redirecting output to the
serial port at that point.  If so, then how do I undo it?
Alternately, do you know offhand what the serial port params are?  I
tried using a Mac modem cable connected to a PC via a null-modem
adapter, but didn't see anything.

Thanks

-- 
Rob Browning <rlb@cs.utexas.edu> PGP=E80E0D04F521A094 532B97F5D64E3930


Reply to: