[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: tarball and possibly missing devs.



On Wed, Aug 05, 1998 at 02:31:49PM +0200, LUTHER Sven wrote:
> 
> > We have now a working dpkg. So normal install with dpkg -i or with
> > dselect.
> > 
> Same old problem, for dpkg t owork, you need a working glibc2 root
> partition, which i don't have. That's why i so much in need of a tarball,
> without it i can not do things easily, but need to resort to tricks like
> that.  

So this is what to do:

Extract everything the way you were.  cd to .../var/lib/dpkg and touch
status, diversions, and alternatives.
dpkg --force-depends -i dpkg_1.4.0.27.deb
dpkg -i ldso_*.deb
dpkg -i libc6_*.deb
and then the others....

> > > i tried booting in this partition and was not able to open a fbdev to
> > > put the console on it, though it worked on my linuxppc rpms/debian hamm
> > > mixed install.
> > 
> > The whole xfree stuff works. Possible a configuration problem.
> > 
> I am not speaking about the xfree stuff, but about the initial console that
> the kernel is supposed to open after it succeeded in mounting the roor
> partition. I have an Amiga1200 with a powerpc603e board. i am running an
> linux-apus kernel with the amifb frambuffer device. I think it is somewhere
> there that the problem is.

The console is opened BEFORE the root partition is mounted.  That's a
kernel problem.

Dan


--  
To UNSUBSCRIBE, email to debian-powerpc-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org


Reply to: