On Sat, Nov 07, 2009 at 11:19:20PM +0200, Niko Tyni wrote:
On Sat, Nov 07, 2009 at 10:04:57PM +0100, Jonas Smedegaard wrote:On Sat, Nov 07, 2009 at 10:25:03PM +0200, Niko Tyni wrote:Please note that at least libjifty-perl libcatalyst-modules-perl libhttp-request-params-perl bugzilla3 have versioned dependencies on either libemail-mime-creator-perl or libemail-mime-modifier-perl, and those won't be satisfied by the Provides: entries. (See policy 7.5) Changing the dependencies to something like libemail-mime-perl (>= xxx) | libemail-mime-creator-perl (>= yyy) should be enough, but this needs to be done before the removal happens to avoid uninstallability problems.Why make fallback to libemail-mime-creator-perl (>= yyy) versioned? I see no need for that.Well, I was talking about current versioned dependencies. I assume the versions are mentioned for a reason. As an example: Package: bugzilla3 Version: 184.108.40.206-3+nmu1 Depends: [...], libemail-mime-modifier-perl (>= 1.442-2), [...] would need to be changed to Depends: [...], libemail-mime-perl (>= 1.900) | libemail-mime-modifier-perl (>= 1.442-2), [...] Sorry if I'm missing something.
Oh, sorry: I saw it wrongly as a suggestion on "no _newer_ versions than this one".
Your previous mail makes perfect sense to me now (I just had a shower, that might have been what freshened up my vision :-P ).
- Jonas -- * Jonas Smedegaard - idealist & Internet-arkitekt * Tlf.: +45 40843136 Website: http://dr.jones.dk/ [x] quote me freely [ ] ask before reusing [ ] keep private
Description: Digital signature