[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: perl-5.005-base conflicting with non-versioned Perl

Darren/Torin/Who Ever... wrote:
-- Start of PGP signed section.
> The current control file for perl-5.005-base looks like this:
> Package: perl-5.005-base
> Version: 5.005.03-0.8
> Architecture: i386
> Pre-Depends: libc6 (>= 2.1), libgdbmg1
> Suggests: perl-5.005
> Conflicts: perl
> Replaces: perl-base
> Provides: perl5-base
> Installed-Size: 1140
> Maintainer: Darren Stalder <torin@daft.com>
> Source: perl-5.005
> Description: The Pathologically Eclectic Rubbish Lister
> This should keep it from being installed if non-versioned Perl is still
> installed.  It occurs to me that should make this
> Conflicts: perl-base
> instead so that if someone has never installed the full Perl package,
> it will still conflict with the perl-base installed.

It won't work.  perl-base is Essential, and perl-5.005-base is not.
Should it be Essential?  What is the whole setup?

Richard Braakman

Reply to: