[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#498138: check for deprecated OCaml -custom linked executable

On Thu, May 14, 2009 at 11:01:53PM +1100, Romain Beauxis wrote:
> > .... urrrmmm, not really. The point here is also the extra need of
> > some language-specific tool which do not appear as lintian
> > dependency. So, even if I've a sympathy for your proposal,
> > reproducibility will not be ensured unless your field also specify
> > which extra package to install to support the required lintian
> > "plugin". But at that point it can be argued that we are getting a bit
> > overkilling ...
> Well, if this set of tests is installed in the build-dep of the
> package, like with dh_ocaml, it will work.

Sure, but unfortunately have no guarantees that build-deps are
installed when you run lintian. Actually, at least in 2 very common
scenarios of lintian execution, build-deps are *not* installed:

1) building using cowbuilder/pbuilder and running lintian outside such
   an environment (all my upload belongs to this scenario)
2) lintian run by the lintian.d.o folks: they do not install build-deps


Stefano Zacchiroli -o- PhD in Computer Science \ PostDoc @ Univ. Paris 7
zack@{upsilon.cc,pps.jussieu.fr,debian.org} -<>- http://upsilon.cc/zack/
Dietro un grande uomo c'è ..|  .  |. Et ne m'en veux pas si je te tutoie
sempre uno zaino ...........| ..: |.... Je dis tu à tous ceux que j'aime

Attachment: signature.asc
Description: Digital signature

Reply to: