[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Help with mirroring setup

On 01/27/2012 01:56 PM, Mitry Matyushkov wrote:
Hi Donald,

On 1/27/2012 8:06 PM, Donald Norwood wrote:

Running ftpsync does populate our local mirror directory but after
awhile we get the following error(s):


rsync: read error: Connection reset by peer (104)
rsync error: error in rsync protocol data stream (code 12) at io.c(760)
rsync: connection unexpectedly closed (236 bytes received so far)
rsync error: error in rsync protocol data stream (code 12) at io.c(601)


ftpsync-[24010]: Mirrorsync done
ftpsync-[24010]: Rsync transfer speed: KB/s
ftpsync-[24010]: Back from rsync with returncode 12
ftpsync-[24010]: ERROR: Sync step 1 went wrong, got errorcode 12.

This has occurred with each mirror we've tried which leads me to believe
that the mirrors choosen do not allow anon rsync

If this was true you couldn't even connect to them.

and that we need to
partner with a push mirror so that our server pulls its data from them.

You'll get the same issue, just believe me. As it was stated on IRC push triggering is just a signal to you which says "Hey, start you ftpsync with me" and nothing more. You need already working ftpsync setup (running manually or via crontab) before initiating push triggered sync.

To the problem: I encountered similar issues when host with slow (untuned) hard drive / file-system tried to sync from our mirror. They were too slow to scan entire debian tree on local disk and rsyncd on my side closed connection decided remote is timed out.

If this is your case I can suggest to use noatime and nodiratime mount options or to use different fs like xfs. Also you may use /sbin/blockdev to set higher disk read ahead.


Hi Mitry,

Thank you for reply and the insight into the filesystem, since this was to be run on a spare machine I reformatted it and used xfs tuning with:

type xfs (rw,noatime,nodiratime,allocsize=64m,sunit=512,swidth=3072)

and it worked perfectly.

Curiously, one of the rsync errors I got earlier from the mirror at debian.fastweb.it, was:

cat log/rsync-ftpsync.error.0
rsync: opendir "/pool/main/libt/libtest-identity-perl" (in debian) failed: Permission denied (13)

Which inspired my anon sync comment but is apparently unrelated.

Best regards,


Reply to: