[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: System halt after a short time


Let's try something to quickly differentiate between your machine and your install.

Are you fortunate enough that you still have an earlier 2.6.17 or other kernel package still installed on the machine? Can you boot the older kernel from the prom? It would be interesting to know if the box comes up.

Perhaps you still have your netboot or CD boot stuff set up from the original install? If you boot into that and just let it sit, does it go down?

If you don't have either of the above, then here's the next best thing to try. Gentoo has a Knoppix like LiveCD that will boot an O2 directly into an X desktop running completely off of the CD.


The directions don't mention that you just wait for the login to timeout and it automatically logs you in as a "user". From there, you can "sudo su -" or something like that to get a root shell.

It would be interesting to know if that comes up and runs. If that is OK, then it might be your 2.6.18 kernel in which case we would have to drop down a replacement.

If booting some other kernel does not "fix" the problem, then it may be the machine. Most likely suspect would be the DRAM. I had an O2 running Irix with a DRAM stick that somehow became marginal over time. The machine would boot up to the graphical login. I would attempt to login and the machine would power off. I tried reseating them... no dice. I had a couple spares, so I started rotating them out two at a time until I found the offending pair. The machine was fine after that.

Good Luck,


On Tue, 3 Apr 2007, Giuseppe Sacco wrote:

Hi all,
I updated my SGI o2 to etch (I updated last time one week ago) and I got
the new kernel package (same version: 2.6.18-4).

No, I cannot boot my system anymore. When I poweron tha machine I see
all messages on the console until exim start. When it is starting the
system goes off.

I tried to start in single user and I noticed that, anything I do, the
machine poweroff after two minuntes and 6 second from the arcboot load.

I mean: I left the machine waiting at the root password prompt; I left
the normal startup process going, I interend single user and typed
command like "date", "sync", "mount".

Anything I do, the machine will poweroff after 2:06 from the start of
linux kernel loading.

Is there any way I could investigate this problem?


To UNSUBSCRIBE, email to debian-mips-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: