[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: unable to boot debian on a IP22

Pierre Letouzey wrote:
> Hi all, 
> I'm currently involved in a compiler course where we use mips assembly
> for pedagogical reasons. Up to recently, we were only using emulators:
> spim, gxemul, maybe qemu some day. That's nice, but not so fun, so I
> searched and found two real pieces of mips hardware: a SGI Indigo
> (IP20) and an Indigo2 (IP22). They're both operational (Irix+NetBSD on
> the IP20, NetBSD on the IP22). But since I'm rather a Debian user than
> a BSD one, I also tried the Debian/mips port:
> - Concerning the IP20, I initially got confused by the Indigo vs. Indy
>   naming convention and tried debian on it, of course with no luck,
>   since (quoting http://www.linux-mips.org/wiki/IP20): 
>     "The indigo is not supported ... Steve Hill is working 
>      on taking the NetBSD port to Linux."
>   Has somebody more infos on this project ? I would be interested in
>   contributing (up to my modest means, e.g. testing stuff, etc). 

The best place to ask that is linux-mips@linux-mips.org, or the
#mipslinux channel at freenode.org.

> - What really puzzled me is my IP22, that obstinately refused to boot
>   all the debian kernels I tried with it (sarge, woody, etch...), even
>   if this machine seems to be supported according to debian docs.
>   Each time, kernel gets downloaded via tftpboot, a message
>   about initrd is displayed, and nothing more (see complete bootlog 
>   and some info found in the PROM at the end of the mail). 
>   -> in my suspect list is the video card, GU1-Extreme, that isn't
>    supported by Xfree/Xorg. Could it prevent me to see anything, from
>    the very start of the kernel booting ?

Yes, since the GU1-Extreme also isn't supported by a Linux console.

>    I would be tempted to answer
>    no, since I've tried today with a DIN-8 serial console cable, that
>    works fine under NetBSD, and allows me to capture the bootlog that
>    follows. But the linux boot stops at the same point as with regular
>    keyboard+screen. Maybe is there some boot parameters to feed into
>    the kernel ?

Boot with "bootp(): append=console=ttyS0", or "setenv console d1"
in the firmware. The installer manual explains that bit further.

>   -> Something wrong with the bootloader ? From my tests with NetBSD,
>   I know that this PROM can only launch ecoff image, not elf. But all
>   the kernel image I've tested are MIPSEB ECOFF executable (according
>   to "file").

It is actually a tip22 image which combines an ECOFF header with an
ELF kernel and a installer initrd.


Reply to: