[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

unable to boot debian on a IP22

Hi all, 

I'm currently involved in a compiler course where we use mips assembly
for pedagogical reasons. Up to recently, we were only using emulators:
spim, gxemul, maybe qemu some day. That's nice, but not so fun, so I
searched and found two real pieces of mips hardware: a SGI Indigo
(IP20) and an Indigo2 (IP22). They're both operational (Irix+NetBSD on
the IP20, NetBSD on the IP22). But since I'm rather a Debian user than
a BSD one, I also tried the Debian/mips port:

- Concerning the IP20, I initially got confused by the Indigo vs. Indy
  naming convention and tried debian on it, of course with no luck,
  since (quoting http://www.linux-mips.org/wiki/IP20): 
    "The indigo is not supported ... Steve Hill is working 
     on taking the NetBSD port to Linux."
  Has somebody more infos on this project ? I would be interested in
  contributing (up to my modest means, e.g. testing stuff, etc). 

- What really puzzled me is my IP22, that obstinately refused to boot
  all the debian kernels I tried with it (sarge, woody, etch...), even
  if this machine seems to be supported according to debian docs.
  Each time, kernel gets downloaded via tftpboot, a message
  about initrd is displayed, and nothing more (see complete bootlog 
  and some info found in the PROM at the end of the mail). 

  -> in my suspect list is the video card, GU1-Extreme, that isn't
   supported by Xfree/Xorg. Could it prevent me to see anything, from
   the very start of the kernel booting ? I would be tempted to answer
   no, since I've tried today with a DIN-8 serial console cable, that
   works fine under NetBSD, and allows me to capture the bootlog that
   follows. But the linux boot stops at the same point as with regular
   keyboard+screen. Maybe is there some boot parameters to feed into
   the kernel ? 

  -> Something wrong with the bootloader ? From my tests with NetBSD,
  I know that this PROM can only launch ecoff image, not elf. But all
  the kernel image I've tested are MIPSEB ECOFF executable (according
  to "file").

  -> Could it be something wrong with the processor (R4000) ?

To sum up, any hints/suggestion would be greatly appreciated...
Pierre Letouzey


                         Running power-on diagnostics...

                           Starting up the system...

               To perform system maintenance instead, press <Esc>
Setting $netaddr to (from server )

System Maintenance Menu

1) Start System

3) Run Diagnostics

5) Enter Command Monitor

Option? 5
Command Monitor.  Type "exit" to return to the menu.

>> printenv

>> hinv -v -t -p
system ARC SGI-IP22 key 0
  processor CPU MIPS-R4000 key 0
    processor FPU MIPS-R4000FPC key 0
    cache primary icache 8 Kbytes (block 1 lines, line 16 bytes)
    cache primary dcache 8 Kbytes (block 1 lines, line 16 bytes)
    cache secondary cache 1024 Kbytes (block 1 lines, line 128 bytes)
    memory main 64 Mbytes
  controller display SGI-GU1-Extreme key 0 ( ConsoleOut Output )
  p: video(0)
    peripheral monitor key 0
    p: video(0)monitor(0)
  controller network ec0 key 0
  v: net SEEQ NQ8003 - type: Ethernet MTU: 1500 HW: 8:0:69:7:51:6e
  p: network(0)
    peripheral network key 0 ( Input Output )
    p: network(0)network(0)
  adapter SCSI WD33C93B key 0
  p: scsi(0)
  adapter SCSI WD33C93B key 1
  p: scsi(1)
  controller serial IP22 tty key 0
  p: serial(0)
    peripheral line key 0 ( ConsoleIn ConsoleOut Input Output )
    p: serial(0)line(0)
  controller serial IP22 tty key 1
  p: serial(1)
    peripheral line key 0 ( ConsoleIn ConsoleOut Input Output )
    p: serial(1)line(0)
  controller audio HAL2 key 16 ( Input Output )
  p: audio(16)
  controller keyboard pc kbd key 0
  p: key(0)
    peripheral keyboard key 0 ( ReadOnly ConsoleIn Input )
    p: key(0)keyboard(0)
  controller pointer pcms key 0
  p: pointer(0)
    peripheral pointer key 0 ( ReadOnly Input )
    p: pointer(0)pointer(0)

>> bootp():
Setting $netaddr to (from server )
Obtaining  from server 
         7616   +9809632   +64 entry: 0x888020d0
tip22: IP22 Linux tftpboot loader
Loading program segment 1 at 0x0, size = 0xZeroing memory at 0x88004000, size = 0x0
Starting kernel; entry point = 0x883c4000
Copied initrd from 0x88ec17c0 to 0x88456000 (0x29d4d4 bytes)

Reply to: