[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Kernel boot parameter on mips (SGI)

Hi Jens,

On Wed, 1 Nov 2006 09:07:52 +0100
Jens Seidel <jensseidel@users.sf.net> wrote:
> I tested an install on a SGI Octane using the kernel
> linux-image-2.6-r10k-ip30 (2.6.12-3) from experimental.
> I failed to mount the root filesystem (I tried really everything, such
> as an NFS root (fails probably because of kernel network settings), a
> copy of a boostraped system on /dev/sdb directly in my IRIX system)
Booting from SCSI failed for me, because it didn't find any devices on
the SCSI controller. Maybe it's just because I have too much RAM
(2.5GB), haven't tried with 'mem=768M'

> bootp(): append="arg1 arg2"
> is interpreted as kernel command line "append=arg1 arg2" by the
> kernel. So it is necessary to omit "append=" and the quotes.
> Comments? Maybe it's only my system which doesn't support "append"?
Same here, I had to boot with 
 bootp(): root=/dev/ram0 
to get the gentoo boot image working. From this boot image I followed
the steps in the gentoo install guide (stage3 of course :-)), then
started a debootstrap on an empty partition and built the kernel in the
gentoo partition... (what a waste of time to build the gcc without the
need to use it ;->) Be aware that tar may be broken in the installer and
leave you with some files like "some_file.h0644" (i.e. file mode
appended to the file name). Fix by renaming ;-) 

> Next step I will try is to cross compile a newer kernel from
> http://www.linux-mips.org. My first attempt failed because
> linux- seems not to support IP30 anymore. I will try
> different versions or directly from git ...
You need the patches from http://www.linux-mips.org/~skylark/
(... or the gentoo kernel)


Reply to: