[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Etch running on an emulated DECstation

Michel Lespinasse wrote:
On Sat, Sep 16, 2006 at 07:16:36PM +1000, Paul Whittaker wrote:
FYI, I have Etch working on an actual DECsystem 5000/260. The Debianised kernel works OK (although kernels that I have subsequently built myself based on the latest Debian patch set have strange DZ serial console problems), but the Etch Beta 3 netinst installer CD is badly broken (and still was in daily snapshots as at about a week ago). I had to use a Sarge netinst CD to bootstrap to stable and then upgrade to testing from there.

Yay, working 2.6 install, that's great news !

You refer to a working kernel, is that vmlinux-2.6.16-2-r3k-kn02
with a size of 3760367 bytes ? Because that one definitely does not work
well with the emulator. Could be an emulator bug though
(Having booted the system)

No, the vmlinux-2.6.16-2-r4k-kn04 with size = 3643782 and md5sum = 3d186e46dc7c52ce94595297314751e1 (DECstation 5000/240 = R3000A, 5000/260 = R4400) . Although I'm pretty sure that I also tried the kernel you're referring to on my 2000/240 at one point and it worked also. Or was that the Sarge 2.4 kn02 kernel? I can't recall.

Also, a couple of documentation suggestions:

- Delo is rather badly documented. In particular, you need to know how to boot an alternate delo.conf entry (eg. "boot 3/rz6 1/linux-kn02" to boot the netinst CD using the R3000 CPU image rather than the default R4000 one). Moreover, if you add "console=ttyS2" you need to add "initrd=/boot/initrd.gz ramdisk_size=8192" as well because command line arguments will clobber the Delo defaults rather than append to them. - The installer doesn't make it sufficiently clear when performing custom partitioning that a PC partition table must be created prior to creating partitions in order for Delo to work at all, and that a PC partition table does not currently exist. I've seen an archived posting to this list where someone obviously made the same mistake that I did when installing to disks formatted using a non-Linux distro (Ultrix or *BSD). I thought that the installer had created a /dev/sda1 whereas it actually formatted (mkfs.ext3'ed) /dev/sda, such that Delo barfed upon booting. - It might not be immediately obvious to all (although it was to me) that the netinst CD erroring whilst attempting to autodetect a keyboard on a headless system is completely harmless.

Reply to: