[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Some SGI O2 questions



Michael Dosser wrote:
> Hi,
> 
> I have bought a SGI O2 with an R5K processor and 1GB RAM. Nice machine.
> I have successfully installed Debian/unstable on the 2GB disk following
> the instructions and using the image from Martin Michlmayr.
> I want to use this machine as a replacement for my SGI I2 which
> currently serves as a shell server: The I2 has too less RAM (only 256 MB
> are recognized by Linux).
> 
> Here comes a couple of questions:
> 
> - Is it possible to install testing on it or does this make no sense at
>   all? Are there images available?

The current beta2 of debian-installer is still based on 2.4.27, and has
no O2 support. The plan is to upgrade the installer once the kernel
proves for a while to hold up, this may uncover some snags for the
2.4 -> 2.6 transition.

Currently ypu best option is to install from Martin's image and then
upgrade to testing.

> - Login via ssh takes quite a long time: after displaying the motd it
>   takes about six seconds to give you a shell prompt. Why does it take
>   so long? Is this ``normal'' on the O2?

It is only a 180 MHz R5000, in terms of CPU power your I2 might be
faster.

> - I have tested the memory with memtester and it seems to be ok. Then I
>   wanted to apt-get the kernel sources for the running kernel
>   (2.6.16-1-r5k-ip32) and did not find them ... I tried this because I
>   wanted to stress test the machine. How do I check out the Debian
>   kernel source?

Add in /etc/apt/sources.list a deb-src line similiar to the already
existing deb line. See also: man sources.list.

> - I have downloaded the tarball for linux-2.6.16.1 from linux-mips.org
>   to compile a custom kernel. The kernel didn't boot. I then took the
>   config for the running kernel, did a ``make oldconfig'' and then I ran
>   ``make-kpkg kernel_image'' and had a debian package. I installed it,
>   rebootet and the kernel again hanged at ``Starting ELF64 kernel''.
>   What patches are in the Debian kernel which makes it boot? ;)

They are probably unrelated to this problem. What you see is the last
message printed by the bootloader, which then fails to start the kernel.

AFAIR this indicates you used vmlinux instead of vmlinux.32.

> - Can anybody recommend a not so hot scsi sca disk for the O2? I wanted
>   to buy a new one greater or equal 36 GB but the O2 has no direct case
>   cooling possibilities so I expect the 10 or 15K disk to get quite hot
>   ... Are there any experiences?
> - What pci network adapters are supported? Is it possible to use a ata
>   or even sata pci controller and is it possible to even boot from it?
>   I assume this is not supported but it's always better to ask to be sure ;)

This is mostly undiscovered territory, you have to experiment. Some
people in the #mipslinux IRC channel at freenode.org know probably
more. I guess you can't boot from the PCI slot since the firmware
won't know much about the card.


Thiemo



Reply to: