[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

kernel compilation (freeswan?)

I'm struggling to get a kernel to build for my Indigo2.  I'd like to
recompile so I can include the FreeS/WAN IPsec patch, which I certainly
hope will actually work on MIPS.

The problems I have, though, don't seem to have anything to do with that
particular patch.

I'm using kernel-source-2.4.19 + kernel-patch-2.4.19-mips from sid, and
the .config file is exactly the same as /boot/config-2.4.19-r4k-ip22 as
installed by the pre-compild kernel package in the sid archive, with the
exception of the addition IPsec options.

The build fails here after just under 1 hour:
gcc -D__KERNEL__ -I/usr/src/kernel-source-2.4.19/include -Wall -Wstrict-prototyp
es -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -fomit-frame-pointer -I /
usr/src/kernel-source-2.4.19/include/asm/gcc -G 0 -mno-abicalls -fno-pic -pipe -
mtune=r4600 -mips2 -Wa,--trap   -nostdinc -I /usr/lib/gcc-lib/mips-linux/3.3.1/i
nclude -DKBUILD_BASENAME=arc_con  -c -o arc_con.o arc_con.c
arc_con.c:53: warning: initialization from incompatible pointer type
arc_con.c:55: warning: initialization makes integer from pointer without a cast
arc_con.c:55: error: initializer element is not computable at load time
arc_con.c:55: error: (near initialization for `arc_cons.flags')
arc_con.c:60: warning: excess elements in struct initializer
arc_con.c:60: warning: (near initialization for `arc_cons')
make[3]: *** [arc_con.o] Error 1
make[3]: Leaving directory `/usr/src/kernel-source-2.4.19/arch/mips/arc'
make[2]: *** [first_rule] Error 2
make[2]: Leaving directory `/usr/src/kernel-source-2.4.19/arch/mips/arc'
make[1]: *** [_dir_arch/mips/arc] Error 2
make[1]: Leaving directory `/usr/src/kernel-source-2.4.19'
make: *** [stamp-build] Error 2

I've tried disabling arc console support in .config, but then the build
fails doing something related to the Newport console code.  Since the
Indigo2 doesn't even have that, I tried disabling it too, but then it
failed elsewhere.  I don't have the specific messages to post in those
cases, and I don't have time right now to start a build and come back in
an hour to find out where it failed.  I can at some point, though.

My only guess is that I need to use some other compiler.  What version
of gcc was used to build the kernel images in the sid archive?


Attachment: pgpUD519uMkpW.pgp
Description: PGP signature

Reply to: