[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#935928: RFS: assaultcube-data/ -- data files and documentation for AssaultCube

Hi Tobias,

> (After your last mail I'm not sure if you are still working in the
> package, if not please let us know to get the metadata right)

I'm a little sad about the progress of the comments, but that's fine, if you
want to fix the package for me, feel free.

Of course, I will not say that I will never contribute to Debian again, because
from time to time other packages I worked with will need to be updated in the
future. :)

> Nethertheless, as assaultcube-data is now in a limbo state, and needs an
> upload so that the package can be actually be used, a review:
> d/changelog:
>  - debian revisions -3 was never uploaded, it cannot be marked as
>    uploaded to sid. So you have now two options
>    - join the entries for -3 and -4 and release them as -3
>    - mark the entries for -3 as UNRELEASED.
>   (The first option is preferred.)
>  - the changelog entry for -4… There is no change on the "Suggests"
>    part?
> Regarding #935669… I don't thnk your update of the breaks/replaces stancas
> will fix this. First, the bug is because the (non-free) package has been
> uploaded source only, second, the breaks/replace's purpose is a
> different one:
> https://www.debian.org/doc/debian-policy/ch-relationships.html#overwriting-files-in-other-packages
> It was likely introduced because of that, but the version is so old that
> it could be removed now. (As said, #935669 is a different issue)
> To ensure that assaultcube is also updated, a simple Breaks:
> assaultcube ( << should do it, but the games packages I've checked
> do not bother with that, so probably it can be left as it; It just needs
> to be properly uploaded or marked as builddable on the buildds.

This is my first package I would like to adopt and I had difficulty in
"d/control", when an RC appeared in the package, I tried to fix the versions. I
was afraid of receiving even greater criticism.

I continued studying at this link:

> d/watch does not point to upsteam but to your own gitlab clone.
> Please don't do that. You are NOT upstream and repacking is not a valid
> reason to fork a project. (FTR, upstream is here:
> https://github.com/assaultcube/AC)
> This remark is also true for e.g. d/copyright and d/source/metadata)

The latest version of upstream uses older SDLv1 libraries [0]. But it has an
"experimental" branch where they worked with SDLv2 [1], where I mirrored my
account where I made a release [3].

[0] https://github.com/assaultcube/AC/releases/tag/v1.2.0.2

[1] https://github.com/assaultcube/AC/tree/experimental

[2] https://gitlab.com/coringao/assaultcube

I do not know can give problems if the upstream version is the old version.

I can even make changes that you have guided me if it does not cause you


⢀⣴⠾⠻⢶⣦⠀ Carlos Donizete Froes [a.k.a coringao]
⣾⠁⢠⠒⠀⣿⡁ Debian Wiki: https://wiki.debian.org/coringao
⢿⡄⠘⠷⠚⠋⠀ GPG: 4096R/B638B780
⠈⠳⣄⠀⠀⠀  2157 630B D441 A775 BEFF  D35F FA63 ADA6 B638 B780

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: