[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: SBuild: Post-build fails to fetch some packages

Hi Ben,

sbuild maintainer here. In these cases you can always file a bug but lets see
if we can solve this here.

Quoting Ben Finney (2017-07-01 13:08:17)
> Andreas Moog <andreas.moog@warperbbs.de> writes:
> > Your sbuild-environment has outdated mirror information. For example
> > the current libreadline version in unstable is 7.0-3. Does the build
> > work after running sbuild-update?
> The ‘sbuild’ process updates from the mirrors when it begins:
> ====
> +------------------------------------------------------------------------------+
> | Update chroot                                                                |
> +------------------------------------------------------------------------------+
> Get:1 http://mirror.internode.on.net/pub/debian unstable InRelease [255 kB]
> Get:2 http://mirror.internode.on.net/pub/debian unstable/main Sources.diff/Index [27.9 kB]
> Get:3 http://mirror.internode.on.net/pub/debian unstable/main amd64 Packages.diff/Index [27.9 kB]
> Ign:2 http://mirror.internode.on.net/pub/debian unstable/main Sources.diff/Index
> Ign:3 http://mirror.internode.on.net/pub/debian unstable/main amd64 Packages.diff/Index
> Get:4 http://mirror.internode.on.net/pub/debian unstable/main Sources [7488 kB]
> Get:5 http://mirror.internode.on.net/pub/debian unstable/main amd64 Packages [7559 kB]
> Fetched 15.4 MB in 29s (523 kB/s)
> […]
> =====
> yet fails to download packages as before.

That's to be expected because the updating that sbuild does happens in its own
schroot session (assuming you use the default schroot backend) and whatever is
done in that session gets discarded after sbuild closes the session that was
used for building. Autopkgtest then opens its own schroot session in which
nothing that sbuild did with it exists anymore.

I see that your sbuild is running autopkgtest even though you didn't tell it to
do so on the command line. In this case it would also be helpful to see all
your non-default modifications from your ~/.sbuildrc

> To be sure, I ran ‘sudo sbuild-update --upgrade --dist unstable’ before
> another ‘sbuild’ and got the same result.

Did you read the sbuild-update man page? There are a couple of problems with
the command as you are running it.

Firstly, there is no --dist option. The chroot is supplied as a positional

Secondly, just using --upgrade will do nothing unless you also --update the
chroot. If you only "apt-get upgrade" without "apt-get update" then apt did not
yet learn that mirrors have newer versions of your packages and nothing will be

As it says at the bottom of the man page, you can easily do an update,
(dist-)upgrade, clean, autoclean and autoremove in one go by doing:

    % sbuild-update -udcar unstable

Does that fix your problem?


cheers, josch

Attachment: signature.asc
Description: signature

Reply to: