[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: python-llfuse

* Nikolaus Rath <Nikolaus@rath.org>, 2011-05-21, 14:21:
You have both debian/pyversions and XS-Python-Version field. Please use either one or the other, not both.

Any suggestions which one to keep?

Sorry, obvious after reading the Python policy again. I removed the
pyversions file and changed control to read:

X-Python-Version: >= 2.6

Except that Python Policy (as usual...) doesn't match reality and python-support doesn't read X-Python-Version.

X-Python3-Version: >= 3.0

You don't seem to be building extension for Python 3...

What is "Conflicts: s3ql (<= 0.28)" for?
Both of these are remnants from packaging for an Ubuntu PPA. I'll make sure to remove them.

On second thought, do I really need to remove them? I have been providing llfuse and s3ql .debs for a while, both on Ubuntu PPAs and by direct download. Before version 0.28, llfuse was part of the S3QL package, thus the conflict. I think conflicting may avoid problems for
some people that used these old .debs.

Sound like a use case for Breaks+Replaces, not Conflicts. See Debian Policy 7.6.1 for details.

Anyway, it's probably good idea to document purpose of such non-obvious parts of packaging in debian/changelog, even if it's first upload to Debian.

Jakub Wilk

Reply to: