[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RFS: Dropbox

* Vincent Cheng <vincentc1208@gmail.com>, 2011-02-19, 02:24:
Dropbox now depends on the following packages: python2.5, python-dbus, libbz2-1.0, libssl0.9.8, libdbus-1-3, libdbus-glib-1-2, libpng12-0, libpopt0, librsync1, libsqlite3-0, libssl0.9.8, libstdc++6, libwxbase2.8-dbg, python-wxgtk2.8, zlib1g, python-simplejson, python-netifaces

(I've chosen python2.5 over python2.6/3.1 because python2.5 includes all the python-related libraries that Dropbox needs, whereas python2.6/3.1 only includes some.)

You can't just replace a Python extension built for one Python version with another built for a different one; in generality, they are not binary-compatible.

Incidentally, none of the Pythons in Debian are binary-compatible with the one embedded in Dropbox.

Nb, I'm not interested in sponsoring this package, please don't Cc me. :)

Jakub Wilk

Reply to: