[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RFS: roxterm (updated package for experimental)

On Sat, 15 Jan 2011 16:26:43 +0800
Kan-Ru Chen <koster@debian.org> wrote:

> OK. When I was doing the final test, roxterm existed immediately after
> launch. 1.18.5-3, however, has no such problem. I suspect it's only my
> environment, x86_64-linux-gnu. Do you have any clue?

I can reproduce this with zsh and nano, but I still don't know what's
causing it. Wen I added -v -x options to zsh it ran normally (aside from
printing lots of extra info). It also works if I run zsh via a wrapper
sh script which does nothing but exec zsh.

I can only guess there's some sort of race condition (possibly involving
std* file descriptors or something to do with LINES and COLUMNS
environment variables?) but I see any reason why this is affecting
roxterm but not gnome-terminal. I've tried changing the point at which
roxterm runs the child command but it didn't help, and changing the
order tends to have side effects such as sizing issues or commands
sometimes not starting until focused.

I tried roxterm in Ubuntu which uses vte_terminal_fork_command_full
instead of vte_terminal_fork_command and that was able to run zsh and
nano, so perhaps vte_terminal_fork_command is bugged?

PS Is this now OT for the list and I should stop Cc'ing it?

Reply to: