[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problem testing with piuparts


What is the proper way to test packages inside chroot?
piuparts fails with error that seem unrelated to my package:

 0m35.5s ERROR: Broken symlinks:
 /usr/lib/python2.4/site-packages/python-support.pth ->

Can you recommend any best practices or helper scripts?

Please, CC.
anatoly t.

---------- Forwarded message ----------
From: anatoly techtonik <techtonik@gmail.com>
Date: Mon, Nov 22, 2010 at 9:44 AM
Subject: Errors with piuparts
To: debian-python <debian-python@lists.debian.org>


I use pbuilder environment on lenny to test new trac-bitten with
piuparts, but the process fails with the broken symlinks error in

$  sudo piuparts -p trac-bitten_0.6b3-1_all.deb -d lenny
 Setting up libjs-jquery (1.2.6-2) ...
 Setting up trac (0.11.1-2.1) ...
 Setting up trac-bitten (0.6b3-1) ...
 Processing triggers for python-support ...
0m34.8s DEBUG: Command ok: ['chroot', '/tmp/tmpg5YLyT', 'apt-get',
'-yf', '--no-remove', 'install']
0m34.8s DEBUG: Starting command: ['chroot', '/tmp/tmpg5YLyT',
'apt-get', 'clean']
0m34.8s DEBUG: Command ok: ['chroot', '/tmp/tmpg5YLyT', 'apt-get', 'clean']
0m34.8s DEBUG: Removing /tmp/tmpg5YLyT/tmp/trac-bitten_0.6b3-1_all.deb
0m34.8s DEBUG: Starting command: ['lsof', '-w', '+D', '/tmp/tmpg5YLyT']
0m35.2s DEBUG: Command failed (status=1), but ignoring error: ['lsof',
'-w', '+D', '/tmp/tmpg5YLyT']
0m35.5s ERROR: Broken symlinks:
 /usr/lib/python2.4/site-packages/python-support.pth ->
0m35.5s DEBUG: Starting command: ['chroot', '/tmp/tmpg5YLyT', 'umount', '/proc']
0m35.5s DEBUG: Command ok: ['chroot', '/tmp/tmpg5YLyT', 'umount', '/proc']
0m35.8s DEBUG: Removed directory tree at /tmp/tmpg5YLyT

How do you test PAPT packages?

anatoly t.

Reply to: