[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: patch error in some arch

Hi, Hideki.

On Jan 13 2010, Hideki Yamane wrote:
> I want your help with build error in some arch.
> As below I got reject with patching, but I built it completely
> in my environment (i386).

> > patching file src/browsers.cpp
> > Hunk #1 FAILED at 4.
> > Hunk #2 FAILED at 20.
> > 2 out of 2 hunks FAILED -- rejects in file src/browsers.cpp
> > Patch browsers.cpp can be reverse-applied

>  Some arch, ia64 and powerpc cannot build this package.
>  https://buildd.debian.org/pkg.cgi?pkg=jd

I suppose here that your patch applies in i386, since you would possibly
not have buit your package (of course, you should double-check it, since
the patch may not have been applied in the build that you generated).

Anyway, are you sure that you can apply the patch without errors? Are
you sure that the patch that is included in the source package is clean?

If you are using the 3.0 quilt format, then you would have to watch out
for you applying the patch (implicitly, via dpkg) and an
automatically-generated patch named debian/patches/debian-*.

>  How do I deal with this error?

I hope that the points listed above are useful in tracking the problem.

Regards, Rogério Brito.

Rogério Brito : rbrito@{ime.usp.br,gmail.com} : GPG key 1024D/7C2CAEB8
http://rb.doesntexist.org : Packages for LaTeX : algorithms.berlios.de
DebianQA: http://qa.debian.org/developer.php?login=rbrito%40ime.usp.br

Reply to: