[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: patch error in some arch

Hi Rogério,

On Wed, 13 Jan 2010 15:02:01 -0200
Rogério Brito <rbrito@ime.usp.br> wrote:
> I suppose here that your patch applies in i386, since you would possibly
> not have buit your package (of course, you should double-check it, since
> the patch may not have been applied in the build that you generated).

 I had built it in sid, and used pbuilder (yes, I love it, thanks to Junichi).

> Anyway, are you sure that you can apply the patch without errors? Are
> you sure that the patch that is included in the source package is clean?

 When I get source from repository, I get below message.

henrich@babytalk:/tmp$ LANG=C apt-get source jd
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Need to get 723kB of source archives.
Get:1 http://ftp.jp.debian.org sid/main jd 1:2.5.5-091228-4 (dsc) [1227B]
Get:2 http://ftp.jp.debian.org sid/main jd 1:2.5.5-091228-4 (tar) [711kB]
Get:3 http://ftp.jp.debian.org sid/main jd 1:2.5.5-091228-4 (diff) [11.2kB]
Fetched 723kB in 5s (121kB/s)
dpkg-source: info: extracting jd in jd-2.5.5-091228
dpkg-source: info: unpacking jd_2.5.5-091228.orig.tar.gz
dpkg-source: info: unpacking jd_2.5.5-091228-4.debian.tar.gz
dpkg-source: info: applying browsers.cpp

 It seems to be OK, and debuild it as

make[1]: Leaving directory `/tmp/jd-2.5.5-091228'
No patch removed
 dpkg-source -b jd-2.5.5-091228
dpkg-source: info: using source format `3.0 (quilt)'
dpkg-source: warning: patches have not been applied, applying them now (use --no-preparation to override)
dpkg-source: info: applying browsers.cpp
dpkg-source: info: building jd using existing ./jd_2.5.5-091228.orig.tar.gz
dpkg-source: info: building jd in jd_2.5.5-091228-4.debian.tar.gz
dpkg-source: info: building jd in jd_2.5.5-091228-4.dsc
 debian/rules build
dh --with quilt build
File series fully applied, ends at patch browsers.cpp
   debian/rules override_dh_auto_configure
make[1]: Entering directory `/tmp/jd-2.5.5-091228'

 It seems to be ok, too.

> If you are using the 3.0 quilt format, then you would have to watch out
> for you applying the patch (implicitly, via dpkg) and an
> automatically-generated patch named debian/patches/debian-*.

$ LANG=C ls -al debian/patches/
total 16
drwxr-xr-x 2 henrich henrich 4096 Jan  1 23:40 .
drwxr-xr-x 5 henrich henrich 4096 Jan 14 10:04 ..
-rw-r--r-- 1 henrich henrich 1274 Jan  1 21:48 browsers.cpp
-rw-r--r-- 1 henrich henrich   13 Jan  1 23:40 series

 No debian-* patches are there :(


 Hideki Yamane     henrich @ debian.or.jp/iijmio-mail.jp

Reply to: