[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RFS: update-inetd (98% popcon; closes ITA and 10 other bugs)

Hi Patrick,

On Mon, Aug 31, 2009 at 08:46:08PM +0200, Patrick Matthäi wrote [edited]:
> > W: update-inetd: manpage-has-errors-from-man
> > usr/share/man/man8/update-inetd.8.gz 200: warning [p 3, 6.0i]: can't
> > break line

not much I can do about this, it's just a long line that gives a syntactic
example so I'd rather refrain from reformatting it (it'd add confusion)

> > I: update-inetd: hyphen-used-as-minus-sign
> > usr/share/man/man8/update-inetd.8.gz:14


> > I: update-inetd: unused-debconf-template update-inetd/title
> > I: update-inetd: unused-debconf-template update-inetd/ask-several-entries
> > I: update-inetd: unused-debconf-template update-inetd/ask-entry-present
> > I: update-inetd: unused-debconf-template update-inetd/ask-remove-entries
> > I: update-inetd: unused-debconf-template update-inetd/ask-disable-entries

These are false positives (I've added an override):

    $ lintian-info -t unused-debconf-template
    N:   In some cases, the template is used but Lintian is unable to determine
    N:   this. Common causes are:
    N:   - the template is not used by the maintainer scripts but is used by a
    N:   program in the package
    N:   If any of the above apply, please install an override.

BTW I took this opportunity to make the xinetd warning less ugly:

--- a/update-inetd
+++ b/update-inetd
-        print STDERR "Note: xinetd seems to be installed but update-inetd does not\n";
-        print STDERR "currently support it. For more information see\n";
-        print STDERR "/usr/share/doc/xinetd/README.Debian and itox(8).\n";
+        print STDERR "Note: xinetd currently is not fully supported by update-inetd.\n";
+        print STDERR "      Please consult /usr/share/doc/xinetd/README.Debian and itox(8).\n";

The .dsc url remains the same.


debtags-organised WNPP bugs: http://members.hellug.gr/serzan/wnpp

Reply to: